このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIPルートとスタティックルートの混在時

RIPルートとスタティックルートが混在するネットワークについて考えます。

 ここでは、同じ宛先におけるRIPルートと、スタティックルートが存在する場合、どちらのルートが優先されるのか検証していきます。

ネットワーク構成は、下図になります。

基本設定

R1ルータ、R2ルータでRIPルーティングするように基本設定を行います。

各ルータの基本コンフィグ、下記のとおりです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.0.1 255.255.0.0
no shutdown
int S0/0/0
ip address 172.17.0.1 255.255.0.0
clock rate 64000
no shutdown
router rip
network 172.16.0.0
network 172.17.0.0

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.17.0.2 255.255.0.0
no shutdown
interface g0/0
ip address 172.18.0.1 255.255.0.0
no shutdown
router rip
network 172.17.0.0
network 172.18.0.0

R1、R2のルーティングテーブルを確認してみます。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.1/32 is directly connected, Serial0/0/0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:17, Serial0/0/0

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:12, Serial0/0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.2/32 is directly connected, Serial0/0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.1/32 is directly connected, GigabitEthernet0/0

R1ルータでは、「172.18.0.0/16」のルート
R2ルータでは、「172.16.0.0/16」のルート

を学習しています。

R1でスタティックルートを設定

R1で「172.18.0.0/16」のルートをスタティックルートで定義します。

R1(config)#ip route 172.18.0.0 255.255.0.0 172.17.0.2

と入力します。

 そして、「show ip route」コマンドで、ルーティングテーブルを確認するとルーティングテーブル上の「172.18.0.0/16」ルートがRIPルートがスタティックルートで置き換わっていることが確認できます。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.1/32 is directly connected, Serial0/0/0
S    172.18.0.0/16 [1/0] via 172.17.0.2

R2でスタティックルートを設定

R2で「172.16.0.0/16」のルートをスタティックルートで定義します。

R2(config)#ip route 172.16.0.0 255.255.0.0 172.17.0.1

と入力します。

 そして、「show ip route」コマンドで、ルーティングテーブルを確認するとルーティングテーブル上の「172.16.0.0/16」ルートがRIPルートがスタティックルートで置き換わっていることが確認できます。

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

S    172.16.0.0/16 [1/0] via 172.17.0.1
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.2/32 is directly connected, Serial0/0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.1/32 is directly connected, GigabitEthernet0/0

アドミニストレーティブディスタンス値

 RIPルートがスタティックルートで置き換わった理由は、アドミニストレーティブディスタンス値が影響しています。アドミニストレーティブディスタンスの値は、低いものほど、信頼度が高いと評価され優先されるようになっています。

アドミニストレーティブディスタンス値は、下表のように定義されています。

経路情報アドミニストレーティブディスタンス値
直接接続0
スタティックルート1
EIGRPサマリ5
外部BGP20
EIGRP内部ルート90
IGRP100
OSPF110
IS-IS115
RIP120
EGP140
EIGRP外部ルート170
内部BGP200
不明(Unkown)255

RIP、スタティックルートのアドミニストレーティブディスタンス値は、それぞれ

RIP         ・・・ 120
スタティックルート ・・・ 1

とになっています。

アドミニストレーティブディスタンス値の低い、スタティックルートが優先されたわけです。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。