このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

ルーティング(ローカルルートとconnected)

各PCとルータとの接続は、クロスケーブルを使います。

PC1、PC3のデフォルトゲートウェイには、「192.168.1.1」を設定します。

PC2、PC4のデフォルトゲートウェイには、「192.168.2.1」を設定します。

基本設定

●Route1のコンフィグ

!
hostname Router1
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!

●Router2のコンフィグ

!
hostname Router2
!
interface g0/0
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface g0/1
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!

設定が、完了したら、動作確認のためpingを行います。

・PC1からPC2へPingを行います。

・PC3からPC4へPingを行います。

pingは成功するはずです。

connected 接続

さて、ルーティングに関する設定をルータで何も行いませんでした。

ルーティングプロトコルを走らせたわけでもありません。

それでは、なぜ、PC1からPC2へ、PC3からPC4へ、Pingが届いたのでしょうか?

ルーティングテーブルを確認するコマンドに、「show ip route」コマンドがあります。

Router1のルーティングテーブルを表示します。

Router1#show ip route

●「show ip route」の出力

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/1

connected 接続

上の出力で、黄色くマークしている部分に注目して下さい。

C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1

「C」というマークが付いています。これは、「connected」と言う意味で、直接そのネットワークへ接続しているという意味です。

 スタティックルートを設定したわけでも、ルーティングプロトコルを走らせたわけでもないのに、このRouter1は、「192.168.1.0/24」、「192.168.2.0/24」の2つのルートを学習済みになっています。

 直接接続しているネットワークに関しては、特に何も設定しなくても、インターフェイスに IPアドレスを設定するだけで、ルーティングテーブルに反映されるようになっています。これを、「connected」と言います。

ローカルルート

次に、Router2のルーティングテーブルを表示してみます。

Router2#show ip route

●「show ip route」の出力

Router2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
L       192.168.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.0/24 is directly connected, GigabitEthernet0/1
L       192.168.2.1/32 is directly connected, GigabitEthernet0/1

Router1とRouter2で、ルーティングテーブルの内容が異なることが分かります。

Router2では、上の出力で、Router1では、なかった黄色くマークしている「L」のルートがあります。

L 192.168.1.1/32 is directly connected, GigabitEthernet0/0
L 192.168.2.1/32 is directly connected, GigabitEthernet0/1

 ルータのインタフェースにIPアドレスを設定すると、直接接続しているルート情報「C」が、ルーティングテーブルに登録されます。

それに加えて、Cisco IOS 15.0以降では、ローカルルートも登録されます。ローカルルートは、「L」で表されます

 ローカルルートは、直接接続されたネットワーク上のインターフェイスに割り当てられる IP アドレスで、IPv4 のローカルルートの場合、プレフィクス長は /32 となります。IPv6 のローカルルートの場合は、プレフィクス長は /128 となります。

 このルート情報は、パケットを転送することが目的ではなく、インターフェイスに宛のパケットを効率的に判断するために用いられます。

 つまり、Cisco IOS 15.0以降を搭載したルータでは、インターフェイスに IPアドレスを設定すると自動的に「C」と「L」のルートが登録されることになります。

Router1のIOSバージョンを確認してみます。

Router1#show version 
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 04:52 by pt_team

Router2のIOSバージョンを確認してみます。

Router2#show version
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 23-Feb-11 14:19 by pt_team

Router2 の IOSバージョンが、15.0以降であることが確認できます。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。