このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

スタティックルーティング(構築例1)

ルーティングテーブルの作成方法は、2つあります。

  • スタティックルーティング(静的ルーティング)
  • ダイナミックルーティング(動的ルーティング)

この2つのアプローチがあります。

ここでは、スタティックルートの設定を行っていきます。

 スタティックルーティングとは、管理者がルータにネットワークのルート情報を手動で教えてあげる方法です。この方法は、宛先へのルートを固定する場合や、宛先へのルートが1つに限定される時に使います。

 スタティックルートの設定は、ルータに対してネットワーク上に存在する全ての宛先ネットワークの情報を教える必要があります。宛先ネットワーク情報が不足する場合、教えていない、宛先へのルーティングが行えなくなります。

 ルータに教えたルート情報は、ルーティングテーブルに追加されます。ルータは、パケットを受信すると、ルーティングテーブルを参照して、隣のルータ(送信インターフェイス)にパケットを配送します。ルーティングテーブルに、宛先ネットワークへのエントリーが見つからない場合、配達不能になるため、パケットを破棄します。

 スタティックルーティングの欠点は、ネットワークの動的な変化に対応できないことです。ある経路に障害が発生した場合、迂回することができません。つまり、ネットワークの変更がある度に、管理者がルータを設定し直さなければなりません。

 長所は、ダイナミックルーティングのようにルーティング情報の交換が行われないので、帯域幅を圧迫しないので帯域幅の節約になります。また、ルート情報が、ルーティングアップデートとしてネットワーク上を流れることがないため、セキュリティ面において高いと言えます。

それでは、下図のシンプルなネットワークを構築します。

基本設定

各ルータの基本設定は、次のようになります。

●Router_Aのコンフィグ

!
hostname Router_A
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 192.168.2.1 255.255.255.0
 clock rate 64000
 no shutdown
!

●Router_Bのコンフィグ

!
hostname Router_B
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 192.168.2.2 255.255.255.0
 no shutdown
!

 ルータは、直接接続しているネットワークに関しては、特にルーティングに関する設定を行わなくても知っています。ただし、インターフェイスにIPアドレスを設定する必要があります。

スタティックルーティングの設定は、ルータが知らないネットワークを設定します。

それでは,Router_AとRouter_Bが知らないネットワークとは、どのネットワークになるのでしょうか?

Router_Aは、直接接続していない、「192.168.3.0」ネットワーク
Router_Bは、直接接続していない、「192.168.1.0」ネットワーク

を知らないことになります。

ここで、気をつけて欲しいのは、通信は、行きと戻りがあるということです。

 例えば、PC_AからPC_Bに通信する場合、Router_Aだけが、「192.168.3.0」を含む全てのルートを持っていて、Router_Bが「192.168.1.0」のルートを知らなかったとします。

宛先のPC_Bには、パケットが届けることができますが、戻りのパケットが、送信元であるPC_Aに届かないことになります。

 PC_AからPC_Bに送られるパケットの宛先ネットワークアドレスは、「192.168.3.0」になりますが、PC_Bに到着後の戻りのパケットの宛先ネットワークアドレスは、「192.168.1.0」になります。このネットワークのルートをRouter_Bが知らないと、戻りのパケットが破棄されてしまうのです。

つまり、

Router_Aには、「192.168.3.0」ネットワークへのルート
Router_Bには、「192.168.1.0」ネットワークへのルート

を教えてあげなければなりません。

スタティックルートの設定

スタティックルートの設定は、次のコマンドを使って設定します。

Router(config)#ip route {ネットワーク} {サブネットマスク} {ネクストホップ | インターフェイス}

Router_Aに「192.168.3.0」ネットワークへのルートを教えてあげるには、

Router_A(config)#ip route 192.168.3.1 255.255.255.0 192.168.2.1

 ネクストホップに、隣のルータのインターフェイスの IPアドレスを指定します。隣のルータのIPアドレスと言っても、何でもいいわけではありません。Router_A は「192.168.3.0」ネットワークへパケットを送るために自分の S0/0/0 インターフェイスから送出するようになるので、その接続先であるRouter_B の S0/0/0 インタフェースの IPアドレスを指定しなければなりません。

 ここでは、ネクストホップの指定の仕方として隣のルータのIPアドレスを指定しましたが、送信インターフェイスを指定してもかまいません。

Router(config)#ip route 192.168.3.1 255.255.255.0 s0/0/0

と指定しても同様にルーティングできます。

ただし、インタフェースを指定できるのは、今回のように、ポイントツーポイント接続の場合のみです。

設定が、完了したら、PC_AからPC_BへPingを行います。

Pingは成功するはずです。

Router_Aのルーティングテーブルを表示します。

スタティックで定義したルートは、「S」で表され、「192.168.3.0/24」のルート情報が確認できます。

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial0/0/0
S    192.168.3.0/24 [1/0] via 192.168.2.2

同様にRouter_Bのルーティングテーブルを表示します。

スタティックで定義したルートは、「S」で表され、「192.168.1.0/24」のルート情報が確認できます。

Gateway of last resort is not set

S    192.168.1.0/24 [1/0] via 192.168.2.1
C    192.168.2.0/24 is directly connected, Serial0/0/0
C    192.168.3.0/24 is directly connected, FastEthernet0/0

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。