このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIPの設定例2(連続サブネット)

 「RIPの設定例1」では、下図のネットワークを RIP で構築しました。ルータは、異なるネットワークの境界に位置しています。

上図を簡単に表現すると

 (172.16.0.0/16)---(ルータ)---(172.17.0.0/16)---(ルータ)---(172.18.0.0/16)

になります。

R1ルータは、「172.16.0.0/16」、「172.17.0.0/16」の異なるネットワークの境界に位置しています。
R2ルータは、「172.17.0.0/16」、「172.18.0.0/16」の異なるネットワークの境界に位置しています。

 今度は、連続サブネット間でルーティングの設定を行います。RIP では、不連続サブネットではルーティングを行うことはできません。これは、後ほど、コンテンツで解説します。

 RIP Version1 は、クラスフルルーティングプロトコルです。つまり、サブネットの概念が実装されていません。IPv4アドレスのクラス単位である、クラスA(/8)、クラスB(/16)、クラスC(/24)のデフォルトのサブネットマスクを使う、ネットワークにおいてのみ、ルーティングを行うことができます。

 しかし、連続するサブネット間では、クラスレスルーティングができてしまうのです。ここでは、このことを検証していきます。

 最初のネットワーク構成図と比べて違いが、分かり難いかと思います。上図は、連続したサブネットでネットワークが構成されています。

 (172.16.1.0/24)---R1---(172.16.2.0/24)---R2---(172.16.3.0/24)

基本設定

まず、基本設定を行います。ホスト名とIPv4アドレスなどを割り振っていきます。

各ルータの基本コンフィグ、下記の通りです。

●基本コンフィグ

hostname R1
int g0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
int S0/0/0
ip address 172.16.2.1 255.255.255.0
clock rate 64000
no shutdown

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.16.2.2 255.255.255.0
no shutdown
interface g0/0
ip address 172.16.3.1 255.255.255.0
no shutdown

RIP Version1の設定

R1ルータでは、RIPの設定を

R1(config)#router rip
R1(config-router)#network 172.16.1.0
R1(config-router)#network 172.16.2.0

R2では、RIPの設定を

R2(config)#router rip
Router(config-router)#network 172.16.2.0
Router(config-router)#network 172.16.3.0

と設定したいところですが、

R1では、RIPの設定を

Router(config)#router rip
Router(config-router)#network 172.16.0.0

R2でも同様に、RIPの設定を

R2(config)#router rip
Router(config-router)#network 172.16.0.0

に設定します。

 RIPの「network」コマンドの設定は、直接接続しているネットワークをクラスフルで指定することで、RIPに紐づけるインターフェイスを指定します。

 ※「network」コマンドは、指定されたネットワークアドレスに含まれるIPアドレスを持つインターフェイスをRIPに関連付けます。

各ルータのRIPのコンフィグは、下記のとおりです。

ところで、

Router_Aで、RIPの設定を

Router(config)#router rip
Router(config-router)#network 172.16.1.0
Router(config-router)#network 172.16.2.0

と間違えて設定しても、自動的に「172.16.0.0」に訂正されます。

「network」コマンドでは、クラスフルでアドレスを指定することに注意して下さい。

●RIPのコンフィグ

●R1のコンフィグ
router rip
network 172.16.0.0

●R2のコンフィグ
router rip
network 172.16.0.0

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

関連コンテンツ