このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIPの設定例1

ここでは、RIP Version1 を設定していきます。

RIPは、ディスタンスベクタ型のルーティングプロトコルです。

ディスタンスベクタ(Distance Vector)の各々の英単語の意味は、下記の通りです。

  • distance:距離
  • vector:方向

「距離」と「方向」に基づいてルーティングを行っています。

 経路情報(ルーティングテーブル)は、30秒ごとに交換しています。Cisco の RIP では、変更を検出するたびにトリガード更新も行われます。メトリックは、ホップカウントのみを採用しており、最良のルートを決定するのに、経由するルータの数だけで判断しています。

それでは、下図のネットワークを RIP Version1で構築していきます。

基本設定

まず、基本設定を行います。ホスト名とIPv4アドレスなどを割り振っていきます。

各ルータの基本コンフィグ、下記のとおりです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.0.1 255.255.0.0
no shutdown
int S0/0/0
ip address 172.17.0.1 255.255.0.0
clock rate 64000
no shutdown

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.17.0.2 255.255.0.0
no shutdown
interface g0/0
ip address 172.18.0.1 255.255.0.0
no shutdown

RIP Version1の設定

RIP Version1 の設定は、以下のようになります。

1.ルーティングプロトコルを選択する。

ルーティングプロトコルに「rip」を指定します。デフォルトでRIPのバージョンは、1になっています。

Router(config)#router rip

2.ネットワークアドレスを指定する。

 ルータに直接接続しているネットワークをクラスフルで指定します。そうすることで、RIPがアドバタイズに使用するインターフェイスを指定します。

Router(config-router)#network {ネットワーク番号}

 上のネットワークの場合、R1は、「172.16.0.0/16」ネットワークと、「172.17.0.0/16」ネットワークに直接接続しているので、RIPの設定は、以下のようになります。

R1(config)#router rip
R1(config-router)#network 172.16.0.0
R1(config-router)#network 172.17.0.0

ネットワークの指定にサブネットマスクは、必要ありません。

各ルータのRIPのコンフィグは、下記のとおりです。

●RIPのコンフィグ

●R1のコンフィグ
router rip
network 172.16.0.0
network 172.17.0.0

●R2のコンフィグ
router rip
network 172.17.0.0
network 172.18.0.0
ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.1/32 is directly connected, Serial0/0/0
R    172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:09, Serial0/0/0

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:21, Serial0/0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.2/32 is directly connected, Serial0/0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.1/32 is directly connected, GigabitEthernet0/0

「R」で表示されているルートは、RIPによって学習したことを意味します。

R1 では、「172.18.0.0/16」のルート
R2 では、「172.16.0.0/16」のルート

を学習していることが分かります。

ルーティングアップデートの確認

・Simulationモードに切り替えます。

「Play Contorols」で「▶|」ボタンをクリックして、1ステップずつ、時を進めてみます。

 IPv4アドレス「255.255.255.255」のブロードキャスト、UDPのポート番号520番で、RIP v1のルーティングアップデートが送信されていることが確認できます。

次の「RIPの検証コマンド」では、設定したRIPを検証するコマンドを紹介していきます。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

関連コンテンツ