このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

OSPFの設定例

ここでは、OSPFの基本設定を解説します。下図のネットワークをOSPFで構成していきます。

OSPFの基本設定

 OSPFを起動させるには、グローバルコンフィグレーションモードで「router ospf」コマンドを入力します。

Router(config)#router ospf {プロセス番号}

プロセス番号: 1~65535

 プロセス番号は、OSPF プロセスを管理する番号で、R1ルータ、R2ルータとで合わせておく必要はありません。プロセス番号は、OSPF プロセスを管理するためのものです。IGRP や EIGRP の AS 番号とは違います。また、エリア番号と合わせる要もありません。

ネットワークとエリアの設定を行います。

 シングルエリアOSPFでは、すべてバックボーンエリアに所属することになるので、「area 0」を指定します。RIP、IGRP、EIGRPと異なり、ネットワークを指定するために、ワイルドカードマスクで、ネットワークを指定します。

Router(config-router)#network {ネットワーク} {ワイルドカードマスク} area 0

上の構成図の場合、R1ルータの OSPF の設定は、次のようになります。

Router_A(config)#router ospf 1
Router_A(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router_A(config-router)#network 172.16.0.0 0.0.0.3 area 0

 使用しているルータの IOS のバージョンが12.0以降でない場合は、「ip subnet-zero」コマンドが必要です。第0サブネットを使用する場合は注意が必要です。

Router(config)#ip subnet-zero

IOS のバージョンが12.0 以降の場合は、デフォルトで第0 サブネットを使用することができます。

帯域幅・コストの設定

帯域幅の設定

 OSPFは、リンクのコストでルートを判断しますので、インターフェイスに適切な帯域幅を設定する必要があります。「bandwidth」コマンドの設定を忘れてもデフォルトの帯域幅が使われますが、OSPF を正しく動作させるには、正しい帯域幅の設定が不可欠です。

Router(config)#interface serial 0/0/0
Router(config-if)#bandwidth 64

コスト値の手動設定

 リンクコストは、インターフェイスコンフィグレーションモードで次のコマンドを指定することでカスタマイズすることができます。

Router(config-if)#ip ospf cost {コスト値}
※コスト値: 1~65,535の範囲で指定します。

 OSPF のリンクのコストは、「108/帯域幅」で求められる値が使われます。つまり、100Mbpsのリンクの場合、コストは1になります。100Mbpsイーサネットと、ギガイーサーネットが混在する環境では、リンクのコストをカスタマイズしなければ、うまく機能しなくなります。

※コストを変更する場合は、他ルータとの整合性を取るため、すべてのOSPFルータで設定変更しておく必要があります。

基準帯域幅の変更

 デフォルトの基準帯域幅は、108(100M)bps です。この基準帯域幅を用いると、100Mbpsのリンクと1Gbpsのリンクのコストが同じ値となってしまいます。

 100Mbps 以上の高速リンクが、すべて1になってしまうため、基準帯域幅を変更することができます。

Router(config-router)#auto-cost reference-bandwidth {ref-bw}
※ref-bw: 1~4,294,969(単位:Mbps)の範囲で指定します。デフォルトは、100となっています。

基準帯域幅を1,000Mbpsに変更した場合のコスト値

コスト = 108 ÷ 帯域幅(bps)

  • 10Mbps   → 100
  • 100Mbps  → 10
  • 1,000Mbps → 1

※基準帯域幅を変更する場合は、他ルータとの整合性を取るため、すべてのOSPFルータで設定変更しておく必要があります。

基本設定

まず、基本設定を行います。ホスト名とIPv4アドレス、OSPFの設定を行います。

 各ルータのイーサネットのインターフェイスは、ギガビットですが、デフォルトの基準帯域幅を用いることにします。

各ルータの基本コンフィグは、下記のとおりです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
int s0/0/0
ip address 172.16.0.1 255.255.255.252
clock rate 64000
bandwidth 64
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0

●R2のコンフィグ
hostname R2
int g0/0
ip address 192.168.3.1 255.255.255.0
no shutdown
int s0/0/0
ip address 172.16.0.2 255.255.255.252
bandwidth 64
no shutdown
router ospf 1
network 192.168.3.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0

ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/30 is directly connected, Serial0/0/0
L       172.16.0.1/32 is directly connected, Serial0/0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
L       192.168.1.1/32 is directly connected, GigabitEthernet0/0
O    192.168.3.0/24 [110/1563] via 172.16.0.2, 00:00:18, Serial0/0/0

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/30 is directly connected, Serial0/0/0
L       172.16.0.2/32 is directly connected, Serial0/0/0
O    192.168.1.0/24 [110/1563] via 172.16.0.1, 00:07:08, Serial0/0/0
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.0/24 is directly connected, GigabitEthernet0/0
L       192.168.3.1/32 is directly connected, GigabitEthernet0/0

R1ルータのルーティングテーブルを確認すると以下のように表示されています。

O 192.168.3.0/24 [110/1563] via 172.16.0.2, 00:00:18, Serial0/0/0

「O」は、OSPF によって学習したことを意味しています。

アドミニストレーティブディスタンスは、「110」であることが分かります。

メトリックは、各リンクの「108/帯域幅」の累計ですから計算式は、以下のようになります。

コスト = (108 / 64,000) + (108 /1 ×109)

(108 / 64,000)  = 1562.5 → 1562
(108 /1 ×109) = 0.1 → 1

つまり、コストは

コスト = (108 / 64,000) + (108 /1 ×109)= 1562 + 1 = 1563

計算式から求められるとおり、「1563」になっています。

 次の「OSPF(Hello間隔・Dead間隔)」では、隣接ルータにおいてのHello間隔・Dead間隔の関係について解説します。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。