このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIP(等コストロードバランシング)その1

 RIPでは、コストの等しいパスをラウンドロビン形式で、ロードバランシングを行うことができます。デフォルトで4本のパスにまたがってロードバランシングを行うことができます。

 「maximum-paths {値}」コマンドを使用することで、最大32本までの、ロードバランシングを行うことができますが、」IOSによって最大値は異なります。値に1を設定することで、。ロードバランシングを無効にすることができます。※Packet Tracer では、「maximum-paths {値}」コマンドはサポートされていないようです。

ちなみに、IGRP、EIGRP では、不等コストロードバランシングもサポートされています。

それでは、下図のネットワークを RIP の等コストロードバランシングの設定を行っていきます。

基本設定

まず、基本設定を行います。ホスト名とIPv4アドレス、RIPv1の設定を行います。

各ルータの基本コンフィグは、下記の通りです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
int S0/0/0
ip address 172.16.2.1 255.255.255.0
clock rate 64000
no shutdown
int S0/0/1
ip address 172.16.3.1 255.255.255.0
clock rate 64000
no shutdown
router rip
network 172.16.0.0
passive-interface g0/0

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.16.2.2 255.255.255.0
no shutdown
int s0/0/1
ip address 172.16.3.2 255.255.255.0
no shutdown
interface g0/0
ip address 172.16.4.1 255.255.255.0
no shutdown
router rip
network 172.16.0.0
passive-interface g0/0

ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1ルータのルーティングテーブル

R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
C       172.16.1.0/24 is directly connected, GigabitEthernet0/0
L       172.16.1.1/32 is directly connected, GigabitEthernet0/0
C       172.16.2.0/24 is directly connected, Serial0/0/0
L       172.16.2.1/32 is directly connected, Serial0/0/0
C       172.16.3.0/24 is directly connected, Serial0/0/1
L       172.16.3.1/32 is directly connected, Serial0/0/1
R       172.16.4.0/24 [120/1] via 172.16.3.2, 00:00:14, Serial0/0/1
                      [120/1] via 172.16.2.2, 00:00:14, Serial0/0/0

●R2ルータのルーティングテーブル

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
R       172.16.1.0/24 [120/1] via 172.16.3.1, 00:00:05, Serial0/0/1
                      [120/1] via 172.16.2.1, 00:00:05, Serial0/0/0
C       172.16.2.0/24 is directly connected, Serial0/0/0
L       172.16.2.2/32 is directly connected, Serial0/0/0
C       172.16.3.0/24 is directly connected, Serial0/0/1
L       172.16.3.2/32 is directly connected, Serial0/0/1
C       172.16.4.0/24 is directly connected, GigabitEthernet0/0
L       172.16.4.1/32 is directly connected, GigabitEthernet0/0

 R1ルータでは、「172.16.4.0」へのルートが2つ、R2ルータでは、「172.16.1.0」へのルートが2つあることが確認できます。

 続きは、「RIP(等コストロードバランシング_その2)」で等コストロードバランシングの動作を確認していきます。

関連コンテンツ