このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

OSPF(DR・BDRの選出 プライオリティ)

 ここでは、OSPFルータに優先度(PRIORITY)を設定した際に DR、BDR の選出において、どのように影響されるかを検証していきます。

DR、BDRについては、「OSPF(DR・BDRの選出)」で解説しています。

OSPF(DR・BDRの選出)」でも解説したように、DR、BDR の選出については、次の3つの項目に着目します。

1.優先度(PRIORITY)
2.ループバックインターフェイスのIPアドレス
3.物理インターフェイスのIPアドレス(アクティブなインターフェイスで最も大きいもの)

優先度 > ループバックインターフェイスのIPアドレス > 物理インターフェイスIPアドレス

の順に注目すれば、どのルータが DR、BDR に選出されるのかが分かります

それでは、下図のネットワークをOSPFで構築します。

 R1ルータでプライオリティ値を設定しています。R2ルータ、R3ルータのプライオリティティは、デフォルトの「1」になり、R1ルータのプライオリティ値が最も高いことになります。DRは、Router_Aが選択されるはずです。

 残りのR2ルータ、R3ルータは、プライオリティ値が同じになるので、ルータIDの大きさで決まることになります。R2ルータには、ループバックアドレスが設定されています。R3ルータは、ループバックアドレスが設定されていないため、アクティブなインターフェイスのIPアドレスで最大のIPアドレスが、ルータIDになります。

そうすると、各ルータのルータIDは次のようになります。

R1ルータ の ルータID ・・・ 192.168.1.1(プライオリティ50)
R2ルータ の ルータID ・・・ 200.200.200.200
R3ルータ の ルータID ・・・ 192.168.1.3

ということは、

R1ルータ ・・・ DR
R2ルータ ・・・ BDR
R3ルータ ・・・ DROTHER

になるはずです。

DR、BDRが、このように選択されるかを、各ルータを設定して検証していきます。

プライオリティの設定

 OSPFで、プライオリティをデフォルト値の「1」から変更するには、インターフェイスコンフィギュレーションモードで「 ip ospf priority」コマンドを使います。

Router(config-if)#ip ospf priority {プライオリティ値}

プライオリティ値は、0~255の間で設定できます。プライオリティ値を「0」にすると、DR、BDRに選出されないようになります。

各機器の設定

 ホスト名とIPv4アドレス、OSPFの設定を行います。R1ルータのプライオリティには「5」を、R2ルータには、ループバックインターフェイスには、IPアドレス「200.200.200.200/32」を設定します。

各ルータ、スイッチの基本コンフィグは、下記のとおりです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 192.168.1.1 255.255.255.0
ip ospf priority 50
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
end
copy run start

●R2のコンフィグ
hostname R2
int lo0
ip address 200.200.200.200 255.255.255.255
int g0/0
ip address 192.168.1.2 255.255.255.0
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
end
copy run start

●R3のコンフィグ
hostname R3
int g0/0
ip address 192.168.1.3 255.255.255.0
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
end
copy run start

●S1のコンフィグ
hostname S1
end
copy run start

 各ルータの設定が完了したら、各ルータで「copy run start」して設定を保存し、R1ルータ~R3ルータの電源を切り、ほぼ同じタイミングで電源を入れます。これは、DR、BDR は、一度、DR、BDR が決定すると、DR、BDR がダウンするまで新しい DR、BDR が選出されないからです。

 設定した順番、もしくは電源を入れた順番で DR、BDR が決定されてしまった場合、後から設定したルータや後から追加したルータは、DR、BDR には選出されません。

 ここでは、下図の「Power Cycle Devices」ボタンをクリックした、ワークスペース上のすべてのデバイスを一度に再起動させます。

コンバージェンスするまで、しばらく待ちます。

「show ip ospf neighbor」コマンドを使って、どのルータがDR、BDRに選出されてか確認していきます。

●R1ルータの「show ip ospf neighbor」の出力

R1#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
200.200.200.200   1   FULL/BDR        00:00:34    192.168.1.2     GigabitEthernet0/0
192.168.1.3       1   FULL/DROTHER    00:00:34    192.168.1.3     GigabitEthernet0/0

●R2ルータの「show ip ospf neighbor」の出力

R2#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1      50   FULL/DR         00:00:36    192.168.1.1     GigabitEthernet0/0
192.168.1.3       1   FULL/DROTHER    00:00:36    192.168.1.3     GigabitEthernet0/0

●R3ルータの「show ip ospf neighbor」の出力

R3#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
200.200.200.200   1   FULL/BDR        00:00:34    192.168.1.2     GigabitEthernet0/0
192.168.1.1      50   FULL/DR         00:00:34    192.168.1.1     GigabitEthernet0/0

 「show ip ospf neighbor」コマンドの出力から分かるように、各ルータは下のようになっていることが確認できます。

R1ルータ ・・・ DR
R2ルータ ・・・ BDR
R3ルータ ・・・ DROTHER

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。