このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIP Version2

 「RIP(不連続サブネットにおける問題)」のコンテンツでは、不連続サブネット環境において、RIPv1ではルーティングできないことを検証しました。

RIPv1には、次の制約があります。

RIPv1の制約

  • アップデート情報にサブネットマスク情報を含めない。
  • アップデート更新は 「255.255.255.255」でブロードキャストする。
  • 認証がない。
  • VLSMやCIDRに対応していない。

そこで、ここでは、RIP v1 の改良版である RIP v2について解説いていきます。

RIPv1、RIPv2の共通点

RIPv2は、RIPv1の改良版だけ合って、共通しているところがたくさんあります。

  • メトリックは、ポップ数だけ(到達不能は、16ホップ)
  • ディスタンスベクタプロトコル
  • ルーティングループを回避するための仕組みとして、ホールドダウンタイマ、スプリット ホライズンを使用する。

RIPv2の特徴

  • アップデート情報にサブネットマスク情報を含める。
  • アップデート更新は 「224.0.0.9」でマルチキャストする。
  • 認証をサポートする。(クリアテキストもしくは、MD5。デフォルトはクリアテキスト)
  • VLSMやCIDRに対応している

 先ほどの「RIP(不連続サブネットにおける問題)」で構築した、下のネットワークを今度は、RIPv2で構築します。設定は、とても簡単です。

Router(config)#router rip
Router(config-router)#version 2

と「version 2」コマンドを追加するだけで設定は完了します。

 Cisco IOS 11.3より古いIOSを使用している場合は、「ip classless」コマンドを設定しないとクラスレスルーティングやデフォルトルートを使うことができません。Packet Tracer では、IOSのバージョンは、12以降であるため、このコマンドを設定する必要はありません。

使用しているIOSのバージョンによっては以下のコマンドが必要です。

Router(config)#ip classless

ネットワークの構成は、下図のとおりです。

RIP V1の設定

ホスト名とIPv4アドレス、RIPv1の設定を行います。各ルータのコンフィグは、以下の通りです。

●RIP V1のコンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
int S0/0/0
ip address 192.168.1.1 255.255.255.0
clock rate 64000
no shutdown
router rip
network 172.16.0.0
network 192.168.1.0
passive-interface g0/0

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 192.168.1.2 255.255.255.0
no shutdown
int g0/0
ip address 172.16.3.1 255.255.255.0
no shutdown
router rip
network 172.16.0.0
network 192.168.1.0
passive-interface g0/0

RIP Version2の設定

R1、R2の各ルータで「version 2」コマンドを追加します。

●R1ルータ

R1(config)#router rip
R1config-router)#version 2

●R2ルータ

R2(config)#router rip
R2(config-router)#version 2

ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
R       172.16.0.0/16 [120/1] via 192.168.1.2, 00:00:23, Serial0/0/0
C       172.16.1.0/24 is directly connected, GigabitEthernet0/0
L       172.16.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0/0
L       192.168.1.1/32 is directly connected, Serial0/0/0

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
R       172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:06, Serial0/0/0
C       172.16.3.0/24 is directly connected, GigabitEthernet0/0
L       172.16.3.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0/0
L       192.168.1.2/32 is directly connected, Serial0/0/0

 R1ルータ、R2ルータにRIPのルートである「172.16.0.0/16」集約されたルートが追加されています。

 R1から「172.16.3.0/24」ネットワークへ対しての pingは成功し、R2から「172.16.1.0/24」ネットワークへ対しての ping も成功します。

RIPアップデート情報の確認

・Simulationモードに切り替えます。

・Edit Filters で、RIPのみを選択します。

・1ステップずつ、時を進めてRIPアップデートの内容を確認します。

・RIPアップデートのパケットの中身を確認します。

RIPアップデートのパケットをクリックして、詳細情報を確認します。

 例えば、①のパケットは、R2へのRIPv2アップデートです。「RIP Route Packet」を確認すると、ネットワークアドレスが「172.16.0.0」、サブネットマスクが「255.255.0.0」でサブネットマスクの情報も、ちゃんと送られていることが確認できます。

 RIP Version2 などの VLSM に対応したルーティングプロトコルでは、サブネットマスクの情報もルーティングアップデートに含めるため、不連続サブネットにおいてもルーティングを行うことができます。

関連コンテンツ

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。