このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIP(不連続サブネットにおける問題)

 RIP Version1 や IGRP は、クラスフルルーティングプロトコルです。ルーティングアップデートの情報の中にサブネットマスクの情報を含めません。

 RIP Version1 や IGRP は、クラスフルルーティングプロトコルですが、下図のように、連続したサブネットを配置した環境では、うまくルーティングできます。

 受信した経路情報が自分のインターフェイスに設定されたネットワークアドレスが同じクラスなら、自分のインターフェイスに設定されたサブネットマスクを適用するからです。このような、推測によるルーティングには、限界があります。

下の図を見て下さい。

先ほどの構成図の「172.16.2.0/24」ネットワークを「192.168.1.0/24」ネットワークに変更してみます。

ネットワークは、

(クラスB)-----(R1)-----(クラスC)-----(R2)-----(クラスB)

ネットワークは、連続するサブネット環境になっていません。

上の構成の場合、RIPでルーティングできるのかを検証していきます。

RIP V1の設定

ホスト名とIPv4アドレス、RIPv1の設定を行います。各ルータのコンフィグは、以下の通りです。

●RIP V1のコンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
int S0/0/0
ip address 192.168.1.1 255.255.255.0
clock rate 64000
no shutdown
router rip
network 172.16.0.0
network 192.168.1.0
passive-interface g0/0

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 192.168.1.2 255.255.255.0
no shutdown
int g0/0
ip address 172.16.3.1 255.255.255.0
no shutdown
router rip
network 172.16.0.0
network 192.168.1.0
passive-interface g0/0

ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.1.0/24 is directly connected, GigabitEthernet0/0
L       172.16.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0/0
L       192.168.1.1/32 is directly connected, Serial0/0/0

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.3.0/24 is directly connected, GigabitEthernet0/0
L       172.16.3.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0/0
L       192.168.1.2/32 is directly connected, Serial0/0/0

R1には、「172.16.3.0/24」のルートがありません。

R2には、「172.16.1.0/24」のルートがありません。

 R1、R2においてRIPで宛先ネットワークを学習しきれていません。当然ながら、R1から「172.16.3.0/24」ネットワークへ対しての ping は失敗しますし、R2から「172.16.1.0/24」ネットワークへ対しての ping も失敗します。

RIPアップデート情報の確認

・Simulationモードに切り替えます。

・Edit Filters で、RIPのみを選択します。

・1ステップずつ、時を進めてRIPアップデートの内容を確認します。

・RIPアップデートのパケットの中身を確認します。

RIPアップデートのパケットをクリックして、詳細情報を確認します。

 例えば、①のパケットは、R2へのRIPアップデートです。「RIP Route Packet」を確認すると、ネットワークアドレスが「172.16.0.0」、サブネットマスクが「0.0.0.0」でサブネットマスクの情報がない経路情報を送られていることが分かります。

 結局のところ、R2は、「172.16.1.0/24」の経路情報を学習することができない状況になってしまっています。この問題を解決するには、サブネットマスクに対応しているルーティングプロトコルを使用する必要があります。

 次は、このネットワークをRIP Version2で構築します。RIP Version2 などの VLSM に対応したルーティングプロトコルでは、サブネットマスクの情報もルーティングアップデートに含めるため、不連続サブネットにおけるこのような問題でも対処できます。

続きは、「RIP Version2」で解説します。

関連コンテンツ

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。