このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

RIPv1・RIPv2の混在時

RIPv1、RIPv2が混在するネットワークでは、どのような状況となるのかを検証していきます。

ネットワークの構成は、下図を使用します。

基本設定

まず、基本設定を行います。

  • R1ルータは、RIPv2で設定します。
  • R2ルータは、RIPv1で設定します。

各ルータの基本コンフィグは、下記の通りです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.0.1 255.255.0.0
no shutdown
int S0/0/0
ip address 172.17.0.1 255.255.0.0
clock rate 64000
no shutdown
router rip
version 2
network 172.16.0.0
network 172.17.0.0
passive-interface g0/0

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.17.0.2 255.255.0.0
no shutdown
interface g0/0
ip address 172.18.0.1 255.255.0.0
no shutdown
router rip
network 172.17.0.0
network 172.18.0.0
passive-interface g0/0

ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.1/32 is directly connected, Serial0/0/0

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:04, Serial0/0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, Serial0/0/0
L       172.17.0.2/32 is directly connected, Serial0/0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.1/32 is directly connected, GigabitEthernet0/0

すると、R1ルータには、RIPルートがないのに対して、R2では、RIPルートが存在します。

 R2ルータは、RIPv1が設定されていますが、 RIPv1 と RIPv2 のアップデート情報を受信します。RIPv1で動作しているにもかかわらず、RIPv2のアップデート情報を処理するのです。送信するのアップデート情報は、RIPv1のみが動作しているため、当然ではありますが、RIPv1のアップデート情報のみを送信します。

実機の場合

 実機であれば、インターフェイスで送受信するRIPのアップデートパケットをどのように処理するのかを、以下のコマンドにより制御することができます。

Router(config-if)ip rip send version {1|2|1 2}

Router(config-if)ip rip receive version {1|2|1 2}

※Packet Tracer では、このコマンドをサポートされてないようです。

debug コマンドで確認

「debug ip rip」コマンドをR1ルータ、R2ルータ上で開始させます。

Router#debug ip rip

●R1の「degub ip rip」の出力

R1#debug ip rip
RIP protocol debugging is on
R1#RIP: ignored v1 packet from 172.17.0.2 (illegal version)
RIP: sending  v2 update to 224.0.0.9 via Serial0/0/0 (172.17.0.1)
RIP: build update entries
      172.16.0.0/16 via 0.0.0.0, metric 1, tag 0
RIP: ignored v1 packet from 172.17.0.2 (illegal version)
RIP: sending  v2 update to 224.0.0.9 via Serial0/0/0 (172.17.0.1)
RIP: build update entries
      172.16.0.0/16 via 0.0.0.0, metric 1, tag 0
RIP: ignored v1 packet from 172.17.0.2 (illegal version)
RIP: sending  v2 update to 224.0.0.9 via Serial0/0/0 (172.17.0.1)
RIP: build update entries
      172.16.0.0/16 via 0.0.0.0, metric 1, tag 0
RIP: ignored v1 packet from 172.17.0.2 (illegal version)
RIP: sending  v2 update to 224.0.0.9 via Serial0/0/0 (172.17.0.1)

R1ルータ上では、RIPv1のアップデート情報が、無視されているのが分かります。

違法なバージョン(illegal version)のv1パケットは、無視された(ignored)とデバッグ情報が出力されています。

●R2の「degub ip rip」の出力

R2#debug ip rip
RIP protocol debugging is on
R2#RIP: sending  v1 update to 255.255.255.255 via Serial0/0/0 (172.17.0.2)
RIP: build update entries
      network 172.18.0.0 metric 1
RIP: received v2 update from 172.17.0.1 on Serial0/0/0
      172.16.0.0/16 via 0.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via Serial0/0/0 (172.17.0.2)
RIP: build update entries
      network 172.18.0.0 metric 1
RIP: received v2 update from 172.17.0.1 on Serial0/0/0
      172.16.0.0/16 via 0.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via Serial0/0/0 (172.17.0.2)
RIP: build update entries
      network 172.18.0.0 metric 1
RIP: received v2 update from 172.17.0.1 on Serial0/0/0
      172.16.0.0/16 via 0.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via Serial0/0/0 (172.17.0.2)

R2ルータでは、RIPv2 パケットが受信できていることが分かります。

 R1ルータには、RIPルートがありませんから、PC1から「172.18.0.0/16」ネットワークへ対しての pingは、もちろん失敗します。

●デバックを止めます。

以下のコマンドを実行します。

Router#undebug all

まとめ

 当然と言えば、当然なのですが、RIPのバージョンが違うとルーティングできません。工夫をすれば、ルーティングを行うようにすることもできますが、オススメはできません。RIP でネットワークを構築する際には、バージョンを統一しておきましょう。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。