IGRP(デフォルトルートの伝播)

※このページで解説している内容は、Packet Tracer が IGRP に対応していないため、Packet Tracer で検証することができません。実機における検証結果を紹介しています。検証に使った実機は、古い機種です。

IGRPのデフォルトルートの伝播について解説します。

 デフォルトルートの設定は、ルーティングプロトコルの種類、IOSのバージョンによって、ルータの動作が異なるため、注意が必要です。ここでは、IGRP によるデフォルトルートの伝搬について解説していきます。

下の図のネットワークを使用します。

 インターネットをシミュレートするために、ISPルータにループバックアドレス、Lo1、lo2を設定します。このループバックアドレスを仮のインターネット宛てのIPアドレスとして代用します。

 上のネットワークの構成では、Router_A、Router_Bにおいて、宛先ネットワークがインターネット向けのルートをデフォルトルートを設定することでルータのルーティングテーブルの小さくすることができます。

 そのデフォルトルートですが、Router_A、Router_Bにおいて、それぞれ静的なデフォルトルート「ip route 0.0.0.0 0.0.0.0」を指定することでもできますし、インターネットへの境界ルータであるRouter_Aで指定したルートを他のIGRPルータに伝播させることもできます。

 IGRPでは 「0.0.0.0」へのルートが分からないため、「ip route 0.0.0.0 0.0.0.0」で指定されてデフォルトルートを伝搬(再配布)することができません。

 そのため、IGRPでは、「ip default-network」コマンドを使用することでルーティングテーブル上の特定のルートエントリにデフォルト候補「*」(Candidate default)マークすることで、デフォルトルートとして伝搬させることが可能です。

「ip default-network」コマンドは、以下のように指定します。

Router(config)#ip default-network {ネットワーク番号}

 「ip default-network」コマンドで指定したネットワークへのルートがデフォルトルートになります。指定したネットワークへ到達するためのネクストホップルータのIPドレスが「Gateway of last resort」になります。

※ただし、デフォルトゲートウェイへの境界ルータのインタフェースがUPしていなければなりません。上の図の場合、Router_AのS0インタフェースがUPしている必要があります。

●Router_Aにて

Router_A(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1
Router_A(config)#ip default-network 172.16.0.0

 「ip route 0.0.0.0 0.0.0.0 172.16.1.1」と設定していますが、Router_A自身のデフォルトルートが必要なため、ここでは設定しています。

Router_A(config)#rotuer igrp 1
Router_A(config-router)#network 172.16.0.0
Router_A(config-router)#network 172.17.0.0

 ここでは、IGRPは、「ip route 0.0.0.0 0.0.0.0」を伝播しないため、「network 172.16.0.0」コマンドを使用しています。

●Router_Bにて

Router_Bでは、デフォルトルートの設定は必要ありません。Router_Aから伝播してきます。

●ISPの設定

!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname ISP
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 10.0.0.1 255.0.0.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 172.16.1.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
ip classless
ip route 172.17.0.0 255.255.255.0 172.16.1.2
ip route 172.18.0.0 255.255.255.0 172.16.1.2
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Aの設定

!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Serial0
 ip address 172.16.1.2 255.255.0.0
 bandwidth 64
 no fair-queue
!
interface Serial1
 ip address 172.17.1.1 255.255.0.0
 bandwidth 64
 clockrate 64000
!
router igrp 1
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
ip default-network 172.16.0.0
ip route 0.0.0.0 0.0.0.0 172.16.1.1
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定

!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
 ip address 172.18.1.1 255.255.0.0
!
interface Serial0
 ip address 172.17.1.2 255.255.0.0
 bandwidth 64
!
router igrp 1
 network 172.17.0.0
 network 172.18.0.0
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_A、RouterBのルーティングテーブルを確認します。

●Router_Aの「show ip route」の出力

Gateway of last resort is 172.16.1.1 to network 0.0.0.0

C*   172.16.0.0/16 is directly connected, Serial0
C    172.17.0.0/16 is directly connected, Serial1
I    172.18.0.0/16 [100/158350] via 172.17.1.2, 00:00:40, Serial1
S*   0.0.0.0/0 [1/0] via 172.16.1.1

「ip default-network 172.16.0.0」で指定したネットワークには「*」でマークが付けられています。

●Router_Bの「show ip router」の出力

Gateway of last resort is 172.17.1.1 to network 172.16.0.0

I*   172.16.0.0/16 [100/160250] via 172.17.1.1, 00:00:15, Serial0
C    172.17.0.0/16 is directly connected, Serial0
C    172.18.0.0/16 is directly connected, Ethernet0

IGRPによってRouter_Aからデフォルトルートが伝播されてきたことが確認できます。

Router_Bからpingを打って動作確認します。

●Router_Bの「ping」の出力

Router_B#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/64 ms
Router_B#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/64 ms

次の「EIGRP(デフォルトルートの伝播)」では、EIGRPのデフォルトルートの伝播について解説します。

関連コンテンツ