このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

OSPF(DR・BDRの選出 ルータID)

ここでは、OSPF ネットワークにおける DR、BDR の選出のされ方について検証していきます。

DR、BDRについては、「OSPF(DR・BDRの選出)」で解説しています。

 「OSPF(DR・BDRの選出)」でも解説したように、DR、BDR の選出については、次の3つの項目に着目します。

  1. 優先度(PRIORITY)
  2. ループバックインターフェイスの IPアドレス
  3. 物理インターフェイスの IPアドレス(アクティブなインターフェイスで最大なもの)

優先度 > ループバックインターフェイスの IPアドレス > 物理インターフェイス IPアドレス

の順に注目していけばどのルータが DR、BDR に選出されるのかが分かります

それでは、下図のネットワークを OSPF で構築して確認していきます。

 プライオリティ値の設定は行わないので、R1ルータ ~ R3ルータのプライオリティティは、デフォルトの「1」となります。そうすると、全てのルータのプライオリティ値が同じ値となります。プライオリティでは、順位を決めることができないため、今度は、ルータIDの大きさで決めることになります。

 R1ルータ ~ R3ルータには、ループバックアドレスが設定されていないため、各ルータのアクティブなインターフェイスの IPアドレスで最大の IPアドレスがルータID になります。

そうすると各ルータのルータID は、次のようになります。

R1ルータ の ルータID ・・・ 192.168.1.1
R2ルータ の ルータID ・・・ 192.168.1.2
R3ルータ の ルータID ・・・ 192.168.1.3

ということは、

R1ルータ ・・・ DROTHER
R2ルータ ・・・ BDR
R3ルータ ・・・ DR

になるはずです。

DR、BDRが、このように選択されるか、各ルータを設定していきます。

基本設定

まず、基本設定を行います。ホスト名とIPv4アドレス、OSPFの設定を行います。

各ルータ、スイッチの基本コンフィグは、下記のとおりです。

●基本コンフィグ

●R1のコンフィグ
hostname R1
int g0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
end
copy run start

●R2のコンフィグ
hostname R2
int g0/0
ip address 192.168.1.2 255.255.255.0
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
end
copy run start

●R3のコンフィグ
hostname R3
int g0/0
ip address 192.168.1.3 255.255.255.0
no shutdown
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
end
copy run start

●S1のコンフィグ
hostname S1
end
copy run start

 各ルータの設定が完了したら、各ルータで「copy run start」で設定を保存していることを確認します。R1ルータ ~ R3ルータの電源を切り、ほぼ同じタイミングで電源を入れる必要があります。これは、DR、BDR は、一度、DR、BDR が決定すると、DR、BDR がダウンするまで新しい DR、BDR が選出されないからです。

 設定した順番、もしくは電源を入れた順番で DR、BDR が決定されてしまった場合、後から設定したルータや後から追加したルータは、DR、BDR に選出されません。

 ここでは、下図の「Power Cycle Devices」ボタンをクリックした、ワークスペース上のすべてのデバイスを一度に再起動させます。

コンバージェンスするまで、しばらく待ちます。

 リンクライトが緑になったら、「show ip ospf neighbor」コマンドを使って、どのルータが DR 、 BDR に選出されてか確認します。

●R1ルータの「show ip ospf neighbor」の出力

R1#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.2       1   FULL/BDR        00:00:38    192.168.1.2     GigabitEthernet0/0
192.168.1.3       1   FULL/DR         00:00:38    192.168.1.3     GigabitEthernet0/0

●R2ルータの「show ip ospf neighbor」の出力

R2#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.3       1   FULL/DR         00:00:37    192.168.1.3     GigabitEthernet0/0
192.168.1.1       1   FULL/DROTHER    00:00:37    192.168.1.1     GigabitEthernet0/0

●R3ルータの「show ip ospf neighbor」の出力

R3#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1       1   FULL/DROTHER    00:00:33    192.168.1.1     GigabitEthernet0/0
192.168.1.2       1   FULL/BDR        00:00:33    192.168.1.2     GigabitEthernet0/0

 「show ip ospf neighbor」コマンドの出力から分かるように、各ルータは下のようになっていることが確認できます。

R1ルータ ・・・ DROTHER
R2ルータ ・・・ BDR
R3ルータ ・・・ DR

 次の「OSPF(DR・BDRの選出 ループバックアドレス)」では、ルータにループバックアドレスを設定した際のDR、BDRの選出のされ方について検証してみます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。