このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

デフォルトルートとip classless

 「ip classless」コマンドを設定すると最善のスーパーネットルートにフォワードすることができるようになります。デフォルトルートを使用する際は、このコマンドを使います。

 「ip classless」コマンドを設定すると、未知のネットワークを宛先とするパケットをデフォルトルートに転送することができるようになります。「ip classless」コマンドの設定がないと、たとえ、デフォルトルートが存在したとしても、そのパケットは、廃棄されてしまいます。

 Cisco IOS 11.3以降を搭載しているCiscoルータでは、デフォルトで、このコマンドが設定されています。Cisco IOS 11.3より古いIOSを使用している場合は、このコマンドを設定しないとクラスレスルーティングやデフォルトルートを使うことができません。

それでは、デフォルトルートを使って、下図のネットワークを構築していきます。

各ルータの、ルートの向きは、下のようになります。

 Router_A、Router_Cのルートの向きにに注目して下さい。全てのルートが一方通行です。上のネットワークは、小さなネットワークでルートの数が少なくて済みますが、規模が大きくなってくると、スタティックルートのエントリーが増えてきます。その際、全てのネットワークのエントリーを定義していくのは、とても面倒です。

そんな時に役立つのがデフォルトルートです。

Router_A Router_B Router_C
172.16.3.0/24 → ← 172.16.1.0/24   ← 172.16.1.0/24
172.16.4.0/24 →   172.16.4.0/24 → ← 172.16.2.0/24

基本設定

まず、基本設定を行います。各ルータの設定は以下のようになります。

●Router_Aのコンフィグ

!
hostname Router_A
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
 no shutdown
!

●Router_Bのコンフィグ

!
hostname Router_B
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.2 255.255.255.0
 no shutdown
!
interface Serial0/0/1
 bandwidth 64
 ip address 172.16.3.1 255.255.255.0
 clock rate 64000
 no shutdown
!
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 172.16.4.0 255.255.255.0 172.16.3.2
!

●Router_Cのコンフィグ

!
hostname Router_C
!
interface FastEthernet0/0
 ip address 172.16.4.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.3.2 255.255.255.0
 no shutdown
!

デフォルトルートの設定

 デフォルトルートは、下図のように、インターネットに接続するルータで設定するケースが多いです。インターネット上の経路は、非常にたくさんあり、数十万経路とも言われています。

 そのインターネット上の全てのルートを把握するのは、事実上、困難ですし、絶えず変化するネットワークにあわせてルータのルーティングテーブルをメンテナンスするのは神業です。

 また、インターネット上の全てのルートをルータのルーティングテーブルに載せるだけのルータのメモリもCPUパワーも不足します。仮に全部ルートを乗せれたとしても、膨大な負荷がルータにかかってしまうことになります。

デフォルトルートの設定

デフォルトルートを指定するには、特別なネットワークアドレスと特別なサブネットマスクを使って設定します。

Router(config)#ip route 0.0.0.0 0.0.0.0 <ネクストホップ>

Rouer_A、Router_C で、デフォルトルートを設定します。

●Rouer_A

Router_A(config-if)#ip route 0.0.0.0 0.0.0.0 172.16.2.2

●Rouer_C

Router_C(config-if)#ip route 0.0.0.0 0.0.0.0 172.16.3.1

デフォルトルートを有効化する

Cisco IOS 11.3より古いIOSを使用している場合は、「ip classless」コマンドを各ルータで、実行します。

Router(config)#ip classless

Packet Tracer の場合、IOS のバージョンが、11.3より新しいため、「ip classless」の設定は必要ありません。I

一応、IOSのバージョンを確認しておきます。

Router_Aで「show version」コマンドを実行します。

Router#show version

Router_A#show version
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 04:52 by pt_team

ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)

System returned to ROM by power-on
System image file is "flash:c1841-advipservicesk9-mz.124-15.T1.bin"

バージョンが、12.4であることが確認できます。

続いて、「show running-config」コマンドを実行します。

(略)
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.2.2 
!

デフォルトで、「ip cclassless」コマンドが設定がされていることが確認できます。

デフォルトルートの確認

Router_Aでルーティングテーブルを表示します。

Gateway of last resort is 172.16.2.2 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial0/0/0
S*   0.0.0.0/0 [1/0] via 172.16.2.2

 「Gateway of last resort is 172.16.2.2 to network 0.0.0.0」というメッセージから、デフォルトゲートウェイが設定されているということが分かります。

 また、「S* 0.0.0.0/0 [1/0] via 172.16.2.2」において、Sに「*」がついています。この「*」表記はデフォルトルートであるということを表しており、このルート情報からもデフォルトルートであることが確認できます。

設定の検証

PC_AからPC_Bにping します。

pingは成功します。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。