このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

EIGRP(手動集約)

 前の「EIGRP(自動集約の問題)」で確認したように EIGRP による自動集約が、必ずしも望ましい結果にならない場合があります。

 このような場合には、自動集約を行わず、手動で経路集約を行って対処していくようになります。ここでは、手動で経路集約を行う方法を解説していきます。

引き続き、ネットワークは、下図のネットワークを用います。

各ルータの基本設定

各ルータの EIGRP の設定を含む基本設定は、以下のようになります。

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
int S0/0/0
ip address 172.16.2.1 255.255.255.0
clock rate 64000
bandwidth 64
no shutdown
int S0/0/1
ip address 172.16.3.1 255.255.255.0
clock rate 125000
bandwidth 125
no shutdown
router eigrp 1
network 172.16.0.0

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.16.2.2 255.255.255.0
bandwidth 64
no shutdown
int s0/0/1
ip address 172.16.3.2 255.255.255.0
bandwidth 125
no shutdown
int g0/0
ip address 172.16.4.1 255.255.255.0
no shutdown
router eigrp 1
network 172.16.0.0

自動集約を無効にするコマンド

 自動集約を無効にするコマンドは、以下のコマンドになります。実行環境によって、「no auto-summary」コマンドを実行しておく必要があります。※今回、使用する実行環境では、自動集約がデフォルトで無効となっているため、実行する必要はありません。

Router(config-router)#no auto-summary

 ルートの自動集約が、デフォルトで行われるかどうかは、Ciscoルータの機種、IOSのバージョンによって変わってきます。今回、Packet Tracer の検証で用いたルータは、Cisco1941ルータです。自動集約を行わせる「auto-summary」が無効になっています。

手動で集約ルートを定義するコマンド

 手動で集約ルートを定義するには、インターフェイスコンフィグレーションモードで「ip summary-address eigrp」コマンドで設定します。

Router(config-if)#ip summary-address eigrp {AS番号} {IPアドレス} {サブネットマスク} {アドミニストレーティブディスタンス}

 アドミニストレーティブディスタンス(AD)の値は、デフォルトで 5 に設定されています。変更する必要がなければ省略できます。変更する場合は、1~255の範囲で設定することができます。

※注意:AD値は、集約ルートであるNull0に対する値となります。アドバタイズする集約ルートに対するものではありません。AD値を 5 という小さい値にすることで、ルーティングテーブルに登録されやすくして、ルーティングループを防いでいます。

各ルータの集約ルートの設定

 今回は、経路集約すべき複数の経路がないため、「ip summary-address eigrp」コマンドで集約経路を設定しなくてもルーティングが可能ですが、今後の集約経路の設定の練習のため、R1ルータ、R2ルータで以下の設定を追加していきます。

●R1ルータの追加設定

R1(config)#interface serial 0/0/0
R1(config-if)#ip summary-address eigrp 1 172.16.1.0 255.255.255.0

●R2ルータの追加設定

R2(config)#interface serial 0/0/0
R2(config-if)#ip summary-address eigrp 1 172.16.3.0 255.255.255.0

ルーティングテーブルの確認

R1ルータ、R2ルータのルーティングテーブルを確認します。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.1.0/24 is directly connected, GigabitEthernet0/0
L       172.16.1.1/32 is directly connected, GigabitEthernet0/0
D       172.16.3.0/24 [90/40514560] via 192.168.1.2, 00:25:23, Serial0/0/0

     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0/0
L       192.168.1.1/32 is directly connected, Serial0/0/0

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.1.0/24 [90/40514560] via 192.168.1.1, 00:21:16, Serial0/0/0
C       172.16.3.0/24 is directly connected, GigabitEthernet0/0
L       172.16.3.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0/0
L       192.168.1.2/32 is directly connected, Serial0/0/0

 各ルータで定義した集約経路が、R1ルータでは「172.16.3.0/24」、R2ルータでは「172.16.1.0/24」という経路が追加されています。

まとめ

 今回、使用したネットワークでは、集約すべき複数の経路がないため、経路集約を行う必要はありません。各ルータが、個別の経路情報を隣接ルータに通知すればよいわけです。しかしながら、ネットワークの形態によっては、自動集約を無効にして、手動で要約しなければならないケースもあります。このケースについては、次の機会に紹介します。

関連コンテンツ

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。