このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習で学ぶネットワーク:スタティックルーティング(構築例2) - YouTube

この動画では、スタティックルートを使用したネットワークの2つ目の構築例について解説しています。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

スタティックルーティング(構築例2)

 「スタティックルーティング(構築例1)」で構築したネットワークは、ルートの向きが一方行で、ルートの向きについて考える必要がありませんでした。

今度は、下図のネットワークをスタティックルートで、ネットワークを構築していきます。

 静的ルートの設定では、宛先ネットワークへ到達するために、隣のどのルータのどのインターフェイスにパケットを渡してやるのかを指定します。

 各ルータの、ルートの向きは、下のようになります。Router_Bのルートの向きに注目して下さい。宛先ネットワークによって、ネクストホップの指定が変わってきます。

Router_A Router_B Router_C
172.16.3.0/24 → ← 172.16.1.0/24   ← 172.16.1.0/24
172.16.4.0/24 →   172.16.4.0/24 → ← 172.16.2.0/24

 ルートの設定では、宛先ネットワークへ到達するために、隣のルータのどのインターフェイスにパケットを渡してやるのか指定します。

※自分(ルータ)のどのインターフェイスからパケットを送信すればよいのかを指示することもできます。

例えば、Router_Bのルートの設定は、以下のようになります。

Router_B(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1
Router_B(config)#ip route 172.16.4.0 255.255.255.0 172.16.3.2

 スタティックルート設定では、ルートの向きに気をつけて下さい。ルーティングテーブルに間違った経路情報があると、正しく宛先にパケットを配送できなくなります。

基本設定

まず、基本設定を行います。

●Router_Aのコンフィグ

!
hostname Router_A
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
 no shutdown
!

●Router_Bのコンフィグ

!
hostname Router_B
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.2 255.255.255.0
 no shutdown
!
interface Serial0/0/1
 bandwidth 64
 ip address 172.16.3.1 255.255.255.0
 clock rate 64000
 no shutdown
!

●Router_Cのコンフィグ

!
hostname Router_C
!
interface FastEthernet0/0
 ip address 172.16.4.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.3.2 255.255.255.0
 no shutdown
!

スタティックルートの設定

各ルータで、スタティックルートを設定していきます。

●Router_A
Router_A(config)#ip route 172.16.3.0 255.255.255.0 172.16.2.2
Router_A(config)#ip route 172.16.4.0 255.255.255.0 172.16.2.2

●Router_B
Router_B(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1
Router_B(config)#ip route 172.16.4.0 255.255.255.0 172.16.3.2

●Router_C
Router_C(config)#ip route 172.16.1.0 255.255.255.0 172.16.3.1
Router_C(config)#ip route 172.16.2.0 255.255.255.0 172.16.3.1

PC_Aから、PC_B にpingを行います。

C:\>ping 172.16.4.100

ping は、成功します。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。