BGP(ピアグループの設定 その1)

BGP(ピアグループとは)」の続きです。

 ピアグループを設定する前に、まずは、下の図のネットワークを構築していきます。

 AS200は、ルートリフレクションで構築し、各ピアは、ループバックアドレスでピアを張ります。

 ループバックアドレスを使ったピア接続は「BGP(基本設定 ループバックでピア その8」で紹介しています。

 ルートリフレクションについては、「BGP(ルートリフレクションとは」で紹介しています。

それでは、上のネットワークを設定しています。

各ルータの設定は、以下のようになります。

●Router_Aの設定

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.0
!
interface Loopback1
 ip address 20.20.20.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.16.0.1 255.255.0.0
!
router bgp 100
 no synchronization
 network 10.10.10.0 mask 255.255.255.0
 network 20.20.20.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 200
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

●Router_Bの設定

!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial0
 ip address 172.17.0.1 255.255.0.0
 clockrate 64000
!
interface Serial1
 ip address 172.18.0.1 255.255.0.0
 clockrate 64000
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 200
 no synchronization
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 route-reflector-client
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 200
 neighbor 3.3.3.3 route-reflector-client
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 172.16.0.1 remote-as 100
 no auto-summary
!
ip classless
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Cの設定


!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_C
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 172.17.0.2 255.255.0.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 200
 no synchronization
 neighbor 1.1.1.1 remote-as 200
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Dの設定

!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Router_D
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0
 ip address 172.18.0.2 255.255.0.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 200
 no synchronization
 neighbor 1.1.1.1 remote-as 200
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

設定が完了したところで、Router_C、Router_Dのルーティングテーブルを確認します。

●Router_Cのルーティングテーブル

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 172.17.0.1, 00:10:25, Serial0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/129] via 172.17.0.1, 00:10:26, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [200/0] via 172.16.0.1, 00:10:06
     20.0.0.0/24 is subnetted, 1 subnets
B       20.20.20.0 [200/0] via 172.16.0.1, 00:10:06
O    172.16.0.0/16 [110/74] via 172.17.0.1, 00:10:26, Serial0
C    172.17.0.0/16 is directly connected, Serial0
O    172.18.0.0/16 [110/128] via 172.17.0.1, 00:10:26, Serial0

●Router_Dのルーティングテーブル

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 172.18.0.1, 00:11:06, Serial0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/129] via 172.18.0.1, 00:11:06, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [200/0] via 172.16.0.1, 00:11:44
     20.0.0.0/24 is subnetted, 1 subnets
B       20.20.20.0 [200/0] via 172.16.0.1, 00:11:44
O    172.16.0.0/16 [110/74] via 172.18.0.1, 00:11:06, Serial0
O    172.17.0.0/16 [110/128] via 172.18.0.1, 00:11:06, Serial0
C    172.18.0.0/16 is directly connected, Serial0

 Router_C、Router_Dのルーティングテーブルに、AS100内のルート「10.10.10.0/24」、「20.20.20.0/24」があります。

続きは、次の「BGP(ピアグループの設定 その2)」では、ピアグループの設定を追加していきます。