PPPoE(設定例2 その3)

PPPoE(設定例2 その2)」の続きです。

ここでは、Router_Cを設定していきます。

※ネットワークの構成としては、NTTのフレッツADSL、B-Flet's経由でISPに接続する構成を想定しています。

Router_C-Router_D間のPPPoE認証の設定

Router_C-Router_D間のPPPoE認証の設定は、次の通りです。

PPPoE認証     : chap
PPPoE認証ID    : client2
PPPoE認証パスワード: cisco

Router_Cの設定

●初期設定

Router(config)#hostname Router_C
Router_C(config)#enable password cisco
Router_C(config)#line vty 0 4
Router_C(config-line)#password cisco
Router_C(config-line)#login
Router_C(config-line)#exit

●PPPoEクライアント認証の設定

Router_C(config)#username client2 password cisco

●PPPoEを有効にする

まず、PPPoEを有効にします。

※vpdnコマンドは、IOS12.3以前とIOS12.4では、異なります。ここで、紹介するvpdnコマンドは、IOS12.3以前のものです。入力後、IOS12.4のコマンドに変換されます。

Router_C(config)#vpdn enable
Router_C(config)#vpdn-group PPPOE
Router_C(config-vpdn)#accept-dialin
Router_C(config-vpdn-req-in)#protocol pppoe
Router_C(config-vpdn-acc-in)#virtual-template 1
Router_C(config-vpdn-acc-in)#local name client2
Router_C(config-vpdn)#

クライアントからのPPPoEネゴシエートを受け付けるように「accept-dialin」を指定します。

Router_C(config-vpdn)#accept-dialin

仮想インタフェース(virtual-template 1)とVPDNを関連付けます。

Router_C(config-vpdn-acc-in)#virtual-template 1

ユーザ名として、PPPoEの認証で使用する認証IDを指定します。

Router_C(config-vpdn)#local name client2

●Ethernet 0 インタフェースの設定

Router_C(config)#interface ethernet 0
Router_C(config-if)#ip address 210.200.200.1 255.255.255.0
Router_C(config-if)#pppoe enable
Router_C(config-if)#no shutdown

●FastEthernet 0 インタフェースの設定

Router_C(config)#interface fastEthernet 0
Router_C(config-if)#ip address 40.40.40.2 255.255.255.0
Router_C(config-if)#no shutdown

●Loopback 0 インタフェースの設定

Router_C(config)#interface loopback 0
Router_C(config-if)#ip address 50.50.50.1 255.255.255.0
Router_C(config-if)#exit
Router_C(config)#interface loopback 1
Router_C(config-if)#ip address 60.60.60.1 255.255.255.0
Router_C(config-if)#exit

●仮想インタフェース(virtual-template)の設定

仮想インタフェースであるvirtual-templateインタフェースを作成し設定します。

Router_C(config)#ip local pool client2-pool 210.200.200.2
Router_C(config)#interface virtual-template 1
Router_C(config-if)#mtu 1454
Router_C(config-if)#ip unnumbered ethernet 0
Router_C(config-if)#peer default ip address pool client2-pool
Router_C(config-if)#ppp authentication chap
Router_C(config-if)#exit

PPPoEクライアントに付与するIPアドレスを指定します。付与するIPアドレスは、pool名と関連付けます。

プールするIPアドレスは、範囲を指定することもできます。

Router_C(config)#ip local pool client2-pool 210.200.200.2

仮想インタフェースのIPアドレスをE0インタフェースと兼用させるため「ip unnumbered」コマンドを使用します。

Router_C(config-if)#ip unnumbered ethernet 0

PPPoEクライアントに付与するIPアドレスのプールを指定します。

Router_C(config-if)#peer default ip address pool client2-pool

●BGP の設定

Router_C(config)#router bgp 200
Router_C(config-router)#no synchronization
Router_C(config-router)#neighbor 40.40.40.1 remote-as 100
Router_C(config-router)#network 40.40.40.0 mask 255.255.255.0
Router_C(config-router)#network 50.50.50.0 mask 255.255.255.0
Router_C(config-router)#network 60.60.60.0 mask 255.255.255.0
Router_C(config-router)#network 210.200.200.0 mask 255.255.255.0
Router_C(config-router)#exit

●再起動

 PPPoEサーバとなるRouter_Cを再起動させます。再起動しないとPPPoEサーバとして機能しない場合があります。

Router_C(config-if)#reload

Router_Dの設定は、次の「PPPoE(設定例2 その4)」で紹介します。

関連コンテンツ