PPPoE(設定例2 その2)

PPPoE(設定例2 その1)」の続きです。

ここでは、Router_Bを設定していきます。

※ネットワークの構成としては、NTTのフレッツADSL、B-Flet's経由でISPに接続する構成を想定しています。

Router_A-Router_B間のPPPoE認証の設定

Router_A-Router_B間のPPPoE認証の設定は、次の通りです。

PPPoE認証     : chap
PPPoE認証ID    : client1
PPPoE認証パスワード: cisco

Router_Bの設定

●初期設定


Router(config)#hostname Router_B
Router_B(config)#enable password cisco
Router_B(config)#line vty 0 4
Router_B(config-line)#password cisco
Router_B(config-line)#login
Router_B(config-line)#exit

●PPPoEクライアント認証の設定

Router_B(config)#username client1 password cisco

●PPPoEを有効にする

まず、PPPoEを有効にします。

※vpdnコマンドは、IOS12.3以前とIOS12.4では、異なります。ここで、紹介するvpdnコマンドは、IOS12.3以前のものです。入力後、IOS12.4のコマンドに変換されます。

Router_B(config)#vpdn enable
Router_B(config)#vpdn-group PPPOE
Router_B(config-vpdn)#accept-dialin
Router_B(config-vpdn-req-in)#protocol pppoe
Router_B(config-vpdn-acc-in)#virtual-template 1
Router_B(config-vpdn-acc-in)#local name client1
Router_B(config-vpdn)#

クライアントからのPPPoEネゴシエートを受け付けるように「accept-dialin」を指定します。

Router_B(config-vpdn)#accept-dialin

仮想インタフェース(virtual-template 1)とVPDNを関連付けます。

Router_B(config-vpdn-acc-in)#virtual-template 1

ユーザ名として、PPPoEの認証で使用する認証IDを指定します。

Router_B(config-vpdn)#local name client1

●Ethernet 0 インタフェースの設定

Router_B(config)#interface ethernet 0
Router_B(config-if)#ip address 200.200.200.1 255.255.255.0
Router_B(config-if)#pppoe enable
Router_B(config-if)#no shutdown

●FastEthernet 0 インタフェースの設定

Router_B(config)#interface fastEthernet 0
Router_B(config-if)#ip address 40.40.40.1 255.255.255.0
Router_B(config-if)#no shutdown

●Loopback 0 インタフェースの設定

Router_B(config)#interface loopback 0
Router_B(config-if)#ip address 20.20.20.1 255.255.255.0
Router_B(config-if)#exit
Router_B(config)#interface loopback 1
Router_B(config-if)#ip address 30.30.30.1 255.255.255.0
Router_B(config-if)#exit

●仮想インタフェース(virtual-template)の設定

仮想インタフェースであるvirtual-templateインタフェースを作成し設定します。

Router_B(config)#ip local pool client1-pool 200.200.200.2
Router_B(config)#interface virtual-template 1
Router_B(config-if)#mtu 1454
Router_B(config-if)#ip unnumbered ethernet 0
Router_B(config-if)#peer default ip address pool client1-pool
Router_B(config-if)#ppp authentication chap
Router_B(config-if)#exit

PPPoEクライアントに付与するIPアドレスを指定します。付与するIPアドレスは、pool名と関連付けます。

プールするIPアドレスは、範囲を指定することもできます。

Router_B(config)#ip local pool client1-pool 200.200.200.2

仮想インタフェースのIPアドレスをE0インタフェースと兼用させるため「ip unnumbered」コマンドを使用します。

Router_B(config-if)#ip unnumbered ethernet 0

PPPoEクライアントに付与するIPアドレスのプールを指定します。

Router_B(config-if)#peer default ip address pool client1-pool

●BGP の設定

Router_B(config)#router bgp 100
Router_B(config-router)#no synchronization
Router_B(config-router)#neighbor 40.40.40.2 remote-as 200
Router_B(config-router)#network 20.20.20.0 mask 255.255.255.0
Router_B(config-router)#network 30.30.30.0 mask 255.255.255.0
Router_B(config-router)#network 40.40.40.0 mask 255.255.255.0
Router_B(config-router)#network 200.200.200.0 mask 255.255.255.0
Router_B(config-router)#exit

●再起動

 PPPoEサーバとなるRouter_Bを再起動させます。再起動しないとPPPoEサーバとして機能しない場合があります。

Router_B(config-if)#reload

Router_Cの設定は、次の「PPPoE(設定例2 その3)」で紹介します。

関連コンテンツ