このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

ルート再配送(RIPとEIGRP)

下図のRIP、EIGRPで構成されたネットワークで再配送の設定を行って通信できるようにします。

ルート再配送(RIPとIGRP)」で紹介した設定とほとんど変わりありません。

RIPとEIGRPの場合でも

シード メトリックのデフォルト値

ルート再配送先のルーティングプロトコルシードメトリックのデフォルト値
RIP無限大
IGRP/EIGRP無限大
OSPF20、BGPの場合は1

 「ルート再配送(再配送の設定)」で解説したように、シードメトリック値を管理者が指定しない場合、デフォルトのシードメトリックが使用されて、再配送は、うまくゆきません。

 RIP、EIGRPのデフォルトのシードメトリック値は、無限大になっています。つまり、シードメトリック値の指定を省略してしまうと到達不能のルートとして扱われてしまいます。

まずは、

シードメトリック値のオプション指定を省略してR1ルータ~R3ルータを設定していきます。

基本設定

 まずは、基本設定から行っていきます。R1ルータはRIPの設定を、R3ルータはEIGRPの設定を行います。R2ルータのルーティングプロトコルの設定は、後から行います。

●R1のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip address 172.16.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#int g0/1
R1(config-if)#ip address 172.17.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#router rip
R1(config-router)#passive-interface g0/0
R1(config-router)#network 172.16.0.0
R1(config-router)#network 172.17.0.0
R1(config-router)#end
R1#copy run start

●R2のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R2
R2(config)#int g0/0
R2(config-if)#ip address 172.17.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#int g0/1
R2(config-if)#ip address 172.18.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-router)#end
R2#copy run start

●R3のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R3
R3(config)#int g0/0
R3(config-if)#ip address 172.18.0.2 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#int g0/1
R3(config-if)#ip address 172.19.0.1 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#router eigrp 100
R3(config-router)#passive-interface g0/1
R3(config-router)#network 172.18.0.0
R3(config-router)#network 172.19.0.0
R3(config-router)#end
R3#copy run start

R2ルータの再配送の設定

 このネットワークでは、R2ルータが、RIP、EIGRPの境界に位置するルータになるため、このルータで再配布の設定します。

●RIPルートの再配送

RIPで学習したルートをEIGRPのAS100へ再配送するように以下のように設定します。

※シードメトリックの指定を省略しますので、デフォルトのシードメトリック値である「無限大」が使われることになり、ルートが再配送されても、到達不能なルートと扱われます。

R2(config)#router eigrp 100
R2(config-router)#redistribute rip
R2(config-router)#network 172.18.0.0

●EIGRPルートの再配送

EIGRP で学習したルートをRIPへ再配送するように以下のように設定します。

R2(config)#router rip
R2(config-router)#redistribute eigrp 100
R2(config-router)#network 172.17.0.0

※シードメトリックの指定を省略しますので、デフォルトのシードメトリック値である「無限大」が使われることになり、ルートが再配送されても、到達不能なルートと扱われます。

ルーティングテーブルの確認

各ルータのルーティングテーブルを確認します。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/1
L       172.17.0.1/32 is directly connected, GigabitEthernet0/1

 「172.18.0.0」「172.19.0.0」のルートがありません。これは、デフォルトのシードメトリック値が「無限大」なので、再配送されたルートが無視されたためです。

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
D    172.19.0.0/16 [90/5376] via 172.18.0.2, 00:01:42, GigabitEthernet0/1

●R3ルータのルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.2/32 is directly connected, GigabitEthernet0/0
     172.19.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.19.0.0/16 is directly connected, GigabitEthernet0/1
L       172.19.0.1/32 is directly connected, GigabitEthernet0/1

 「172.16.0.0」「172.17.0.0」のルートがありません。これは、デフォルトのシードメトリック値が「無限大」なので、再配送されたルートが無視されたためです。

シードメトリック値の指定

ルート再配送を行うR2ルータの再配布の設定にシードメトリックの指定を加えます。

RIPルートの再配送

メトリックの指定の仕方は、「?」機能で確認すると、どんな項目を入力すればよいのか教えてくれます。

R2(config-router)#redistribute rip metric ?
<1-4294967295> Bandwidth metric in Kbits per second

R2(config-router)#redistribute rip metric 10000 ?
<0-4294967295> EIGRP delay metric, in 10 microsecond units

R2(config-router)#redistribute rip metric 10000 100 ?
<0-255> EIGRP reliability metric where 255 is 100% reliable

R2(config-router)#redistribute rip metric 10000 100 255 ?
<1-255> EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

R2(config-router)#redistribute rip metric 10000 100 255 1 ?
<1-65535> EIGRP MTU of the path

R2(config-router)#redistribute rip metric 10000 100 255 1 1500 ?
<cr>

RIPルートの再配送の設定

RIPで学習したルートをOSPFへ再配送するように以下のように設定します。
※設定を省略した場合でも、デフォルトのシードメトリック値である「20」が使われるので、再配送は行われます。

R2(config)#router eigrp 100
R2(config-router)#redistribute rip metric 10000 100 255 1 1500

 「redistribute rip metric 100 subnets」と指定することで、シードメトリック値に「100」を設定しています。「subnets」は、クラスレスルートを再配送させるためのオプションです。このオプションを指定することで、サブネット化された経路情報を再配送できるようになります。
※ここで、構築するネットワークでは、特に「subnets」のオプションは必要ありません。

EIGRPルートの再配送の設定

EIGRPで学習したルートをRIPへ再配送するように再配布の設定にシードメトリックの指定を加えます。

R2(config)#router rip
R2(config-router)#redistribute eigrp 100 metric 10

「redistribute eigrp 100 metric 10」と指定することで、シードメトリック値を「10」に設定します。

シードメトリックの設定が完了したところで、各ルータのルーティングテーブルを確認してみます。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/1
L       172.17.0.1/32 is directly connected, GigabitEthernet0/1
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:01, GigabitEthernet0/1
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:01, GigabitEthernet0/1

  RIPのエントリーが2つ現れています。これは、デフォルトの「無限大」のシードメトリックではなく、「10」が使われたからです。

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:25, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
D    172.19.0.0/16 [90/5376] via 172.18.0.2, 01:06:07, GigabitEthernet0/1

●R3ルータのルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D EX 172.16.0.0/16 [170/281856] via 172.18.0.1, 00:09:23, GigabitEthernet0/0
D EX 172.17.0.0/16 [170/281856] via 172.18.0.1, 00:09:23, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.2/32 is directly connected, GigabitEthernet0/0
     172.19.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.19.0.0/16 is directly connected, GigabitEthernet0/1
L       172.19.0.1/32 is directly connected, GigabitEthernet0/1

 EIGRPのエントリーが2つ現れています。これはデフォルトの「無限大」のシードメトリックではなく、指定したシードメトリックが使われたからです。

EIGRPのエントリーには、「EX」が付いています。

 R2ルータのルーティングテーブルの凡例を確認すると、「EX - EIGRP external」と表示されています。

これは、EIGRPが外部から学習したエントリーであるとこを意味します。

 再配送の設定は、ルーティングプロトコルごとに指定の仕方が、変わってきます。コマンドの続きに「?」を指定して、次のオプションの指定の仕方を確認しながら設定していきましょう。

関連コンテンツ