※このページで解説している内容は、Packet Tracer が ACL のコンソールロギング に対応していないため、検証することができません。実機における検証結果を紹介しています。

ACLとSyslogサーバへの記録(その2)

ACLとSyslogサーバへの記録(その1)」の続きです。

ネットワーク構成は、下図のとおりです。

Syslogサーバに接続するための設定をR1ルータで行います

 Syslogサーバを利用するた場合、正しい時刻を設定する必要があります。それは、時刻が正しくなければ、ログとして意味を失ってしまうからです。Syslogメッセージに正しい日時を記録することは極めて重要なことです。

ルータに正しい日時を設定します。

R1#clock set 01:10:00 oct 20 2011

時間帯を設定します。時間帯の名前と補正地を設定します。

R1(config)#clock timezone jst 9

ルータのタイムスタンプサービスを有効にします。

R1(config)#service timestamps

ルータ上でSyslogメッセージがSyslogサービスへ送信されるようにします。

R1(config)#logging 192.168.1.2

PC1からR2にWeb接続を行います

 ブラウザを起動して、URLに「http://192.168.2.2/」と入力します。表示されたWebページのリンクをクリックし、閲覧します。

Syslogサーバを確認します。

SyslogメッセージがSyslogサービスへ送信されていることが確認できます。

●R1の設定


!
hostname R1
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 ip access-group 100 in
!
logging 192.168.1.2
access-list 100 permit tcp host 192.168.1.3 host 192.168.2.2 eq www log
!

●R2の設定

!
hostname R2
!
interface Ethernet0
 ip address 192.168.2.2 255.255.255.0
!
ip http server
!

関連コンテンツ