このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ルート再配送(再配送の設定)

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

演習ファイルのダウンロード

ルート再配送(再配送の設定)

ルート再配送(redistribute)」で使用したネットワーク構成図を使います。

基本設定

まずは、基本設定から行っていきます。R1ルータはRIPの設定を、R3ルータはOSPFの設定を行います。R2ルータのルーティングプロトコルの設定は、後から行います。

●R1のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip address 172.16.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#int g0/1
R1(config-if)#ip address 172.17.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#router rip
R1(config-router)#ppassive-interface g0/0
R1(config-router)#pnetwork 172.16.0.0
R1(config-router)#pnetwork 172.17.0.0
R1(config-router)#end
R1#copy run start

●R2のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R2
R2(config)#int g0/0
R2(config-if)#ip address 172.17.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#int g0/1
R2(config-if)#ip address 172.18.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-router)#end
R2#copy run start

●R3のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R3
R3(config)#int g0/0
R3(config-if)#ip address 172.18.0.2 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#int g0/1
R3(config-if)#ip address 172.19.0.1 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#router ospf 1
R3(config-router)#passive-interface g0/1
R3(config-router)#network 172.18.0.0 0.0.255.255 area 0
R3(config-router)#network 172.19.0.0 0.0.255.255 area 0
R3(config-router)#end
R3#copy run start

redistributeコマンド

ルート再配送の設定を行うには「redistribute」コマンドを使用します。

ルータコンフィグレーションモードで入力します。コマンドの構文は以下のようになります。

Router(config)#router [protocol1]
Router(config-router)#redistribute [protocol2]

protocol1 : 再配送先(再配送に使うプロトコル)
protocol2 : 再配送元

「protocol2」で取得したルートを「protocol1」で再配送する。

※ルーティングプロトコルによって「protocol1」「protocol2」の後ろの指定の仕方が変わってきます。

上のネットワーク構成の場合は、下の図のようになります。

Router_Bの再配布の設定

R2(config)#router ospf 1
R2(config-router)#redistribute rip
R2(config-router)#network 172.18.0.0 0.0.255.255 area 0
R2(config-router)#router rip
R2(config-router)#redistribute ospf 1
R2(config-router)#network 172.17.0.0
R2(config-router)#end
R2#copy run start

再配布の設定が理解できたところで、ルータを設定していきましょう。

これで、再配布の設定ができたような気がしますが、実は落とし穴があります。

各ルータのルーティングテーブルを確認してみましょう!

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:20, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
O    172.19.0.0/16 [110/2] via 172.18.0.2, 00:03:32, GigabitEthernet0/1

すべてのルートがルーティングテーブルに格納されています。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/1
L       172.17.0.1/32 is directly connected, GigabitEthernet0/1

 あれ!Router_Bで再配布の設定を行っているのに、OSPFネットワークのエントリー「172.18.0.0」「172.19.0.0」がありません。

●R3のルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 172.16.0.0/16 [110/20] via 172.18.0.1, 00:00:22, GigabitEthernet0/0
O E2 172.17.0.0/16 [110/20] via 172.18.0.1, 00:00:22, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.2/32 is directly connected, GigabitEthernet0/0
     172.19.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.19.0.0/16 is directly connected, GigabitEthernet0/1
L       172.19.0.1/32 is directly connected, GigabitEthernet0/1

 RIPネットワークのエントリー「172.16.0.0」「172.17.0.0」が登録されています。「E2」とマークされていることからOSPFの外部ルートであることが分かります。

 ルート再配送を行う上で注意しなければならないのは、異なるルーティングプロトコルでは、メトリックに互換性がないということです!

 再配送を行うには、メトリックを与えておく必要があります。この再配送時に与えるメトリックのことを「シードメトリック」と言います。

ここで、R2ルータの再配布の設定を思い出してみましょう!

!
router rip (再配送に使うプロトコル)
 network 172.17.0.0
 redistribute ospf 1
!
router ospf 1 (再配送に使うプロトコル)
 network 172.18.0.0 0.0.255.255 area 0
 redistribute rip
!

  • 「OSPF」で取得したルートを「RIP」で再配送しています。
  • 「RIP」で取得したルートを「OSPF」で再配送しています。

「OSPF」で取得したルートの「RIP」で再配送

RIPのデフォルトのシードメトリックの値は、「無限大」になっています。

 つまり、再配送するルートは無限大のルートということになり、到達不能なルートとして扱われてしまうのです。

RIPにより再配布されるOSPFのルートは

「172.18.0.0/16」のルート・・・メトリック『無限大』
「172.19.0.0/16」のルート・・・メトリック『無限大』

となってしまい、R1ルータで到達不能なルートとして扱われてしまうのです。

「RIP」で取得したルートの「OSPF」での再配送

OSPFのデフォルトのシードメトリックの値は、「20」になっています。

OSPFにより再配布されるRIPのルートは

「172.16.0.0/16」のルート・・・メトリック『20』
「172.17.0.0/16」のルート・・・メトリック『20』

R3ルータのルーティングテーブルを確認するとメトリック『20』になっていることが確認できます。

O E2 172.16.0.0/16 [110/20] via 172.18.0.1, 00:00:22, GigabitEthernet0/0
O E2 172.17.0.0/16 [110/20] via 172.18.0.1, 00:00:22, GigabitEthernet0/0

まとめ

 再配送の設定は、再配送する向きと再配送先のルーティングプロトコル、再配送元のルーティングプロトコルの指定の仕方がややこしいので、注意が必要です。

 このままでは、再配布の設定が不十分です。再配布の設定は、シードメトリック値の指定も不可欠です。シードメトリックについては、次の「ルート再配送(シードメトリック)」で解説します。

関連コンテンツ