このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

ルート再配送(ループバック活用例)

 「ルート再配送(RIPとOSPF)」では、下図のRIP、OSPFで構成されたネットワークで再配送の設定を行い、通信させました。

ここでは、上図のネットワーク構成をループバックインターフェイスを使って以下のようにします。

PC1、PC2に接続していたG0/0インターフェイスをループバックインターフェイスに変更します。

Loopbackの活用

 ネットワークの規模が大きい演習を行うには実機で行うのであれば、ルータにたくさんのインターフェイスが必要になり、ルータ本体の台数もそれなりに必要になってきます。

WIC-1T=WIC-2T=

 特にルーティングの演習を行うとなると、たくさんのネットワークが必要になりますから、多くのインターフェイス用意しなければなりません。

 Packet Tracer であれば、ルータやインターフェイスを、いくらでも増やすことができますが、ルータを増やせばそのぶん、設定する量も増えてきますし、間違えた設定を行うことも増えてきて、トラブルシューティングに時間を要するようになります。

 ループバックインターフェイスを活用することで、ネットワーク構成をシンプルにしながら、工夫次第で大規模なネットワークを構築することができます。

特にルーティングの演習を行いたい場合などにループバックインターフェイス、重宝するかと思います。

基本設定

 まずは、基本設定から行っていきます。R1ルータはRIPの設定を、R3ルータはOSPFの設定を行います。R2ルータのルーティングプロトコルの設定は、後から行います。

RIPとOSPFの再配布の設定方法については、「ルート再配送(RIPとOSPF)」を参考にして下さい。

●R1のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R1
R1(config)#int loopback0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#int loopback1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#int loopback2
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#int loopback3
R1(config-if)#ip address 192.168.3.1 255.255.255.0
R1(config-if)#int g0/1
R1(config-if)#ip address 172.17.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#router rip
R1(config-router)#network 192.168.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#network 192.168.3.0
R1(config-router)#network 172.17.0.0
R1(config-router)#end
R1#copy run start

●R2のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R2
R2(config)#int g0/0
R2(config-if)#ip address 172.17.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#int g0/1
R2(config-if)#ip address 172.18.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-router)#end
R2#copy run start

●R3のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R3
R3(config)#int g0/0
R3(config-if)#ip address 172.18.0.2 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#int loopback0
R3(config-if)#ip address 172.19.0.1 255.255.255.0
R3(config-if)#int loopback1
R3(config-if)#ip address 172.19.1.1 255.255.255.0
R3(config-if)#int loopback2
R3(config-if)#ip address 172.19.2.1 255.255.255.0
R3(config-if)#int loopback3
R3(config-if)#ip address 172.19.3.1 255.255.255.0
R3(config-if)#router ospf 1
R3(config-router)#network 172.18.0.0 0.0.255.255 area 0
R3(config-router)#network 172.19.0.0 0.0.0.255 area 0
R3(config-router)#network 172.19.1.0 0.0.0.255 area 0
R3(config-router)#network 172.19.2.0 0.0.0.255 area 0
R3(config-router)#network 172.19.3.0 0.0.0.255 area 0
R3(config-router)#end
R3#copy run start

R2ルータの再配送の設定

RIPルートの再配送

RIPで学習したルートをOSPFへ再配送するように以下のように設定します。
※設定を省略した場合でも、デフォルトのシードメトリック値である「20」が使われるため、再配送は行われます。

R2(config)#router ospf 1
R2(config-router)#redistribute rip metric 100 subnets
R2(config-router)#network 172.18.0.0 0.0.255.255 area 0

 「redistribute rip metric 100 subnets」と指定することで、シードメトリック値に「100」を設定しています。「subnets」は、クラスレスルートを再配送させるためのオプションです。このオプションを指定することで、サブネット化された経路情報を再配送できるようになります。

OSPFネットワークへ再配送する際には、「subnets」を指定しておきます。

OSPFルートの再配送

OSPFで学習したルートをRIPへ再配送するように以下のように設定します。

R2(config)#router rip
R2(config-rouiter)#redistribute ospf 1 metric 10
R2(config-router)#network 172.17.0.0

「redistribute ospf 1 metric 10」と指定することで、シードメトリック値を「10」に設定します。

ルーティングテーブルの確認

各ルータのルーティングテーブルを確認します。

●R1のルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/1
L       172.17.0.1/32 is directly connected, GigabitEthernet0/1
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:24, GigabitEthernet0/1
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:24, GigabitEthernet0/1
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.0.0/24 is directly connected, Loopback0
L       192.168.0.1/32 is directly connected, Loopback0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Loopback1
L       192.168.1.1/32 is directly connected, Loopback1
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.0/24 is directly connected, Loopback2
L       192.168.2.1/32 is directly connected, Loopback2
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.0/24 is directly connected, Loopback3
L       192.168.3.1/32 is directly connected, Loopback3

RIPによってOSPFネットワークのルートを学習しています。

●R2のルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
     172.19.0.0/32 is subnetted, 4 subnets
O       172.19.0.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
O       172.19.1.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
O       172.19.2.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
O       172.19.3.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
R    192.168.0.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
R    192.168.1.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
R    192.168.2.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
R    192.168.3.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0

RIPによるルート、OSPFによるルートがあります。

しかし、OSPFのルートは「/32」のルートとなっています。「/24」のルートではありません。

●R3のルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 172.17.0.0/16 [110/100] via 172.18.0.1, 00:15:46, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.2/32 is directly connected, GigabitEthernet0/0
     172.19.0.0/16 is variably subnetted, 8 subnets, 2 masks
C       172.19.0.0/24 is directly connected, Loopback0
L       172.19.0.1/32 is directly connected, Loopback0
C       172.19.1.0/24 is directly connected, Loopback1
L       172.19.1.1/32 is directly connected, Loopback1
C       172.19.2.0/24 is directly connected, Loopback2
L       172.19.2.1/32 is directly connected, Loopback2
C       172.19.3.0/24 is directly connected, Loopback3
L       172.19.3.1/32 is directly connected, Loopback3
O E2 192.168.0.0/24 [110/100] via 172.18.0.1, 00:15:36, GigabitEthernet0/0
O E2 192.168.1.0/24 [110/100] via 172.18.0.1, 00:15:36, GigabitEthernet0/0
O E2 192.168.2.0/24 [110/100] via 172.18.0.1, 00:15:36, GigabitEthernet0/0
O E2 192.168.3.0/24 [110/100] via 172.18.0.1, 00:15:36, GigabitEthernet0/0

OSPFによって外部ルート(E2)として、RIPネットワークのルートを学習しています。

 ルート再配送はできていますが、R2ルータが「/32」のルートを学習しています。R3のループバックインターフェイスに設定した「/24」のルートではありません。ループバックインターフェイスに設置した個別のネットワークが学習できていません。

 規模の大きなルーティングの演習を行いたい場合、ループバックインターフェイスに設定した個別のネットワークを扱いたいケースが、多々出てきます。そのような場合、「/32」のルートは少々厄介です。

OSPFにおけるループバックインターフェイスの扱い

ここから解説している内容は、以下の YouTube 動画の解説で見ることができます。

ここで、R2ルータのルーティングテーブルを再度確認します。黄色のマークのところに注目します。

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
     172.19.0.0/32 is subnetted, 4 subnets
O       172.19.0.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
O       172.19.1.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
O       172.19.2.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
O       172.19.3.1/32 [110/2] via 172.18.0.2, 00:04:17, GigabitEthernet0/1
R    192.168.0.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
R    192.168.1.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
R    192.168.2.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0
R    192.168.3.0/24 [120/1] via 172.17.0.1, 00:00:18, GigabitEthernet0/0

R2ルータのルーティングテーブルには、「/24」のルートではなく「/32」のルートになっています。

 OSPFは、RIPやEIGRPとは異なり、ループバックインターフェイスの扱い方が特殊です。OSPFでは、ループバックインターフェイスのルート情報を「/32」のホストルートとしてアドバタイズするようになっています。

R2のルート 方向R3のルート
172.19.0.1/32172.19.0.1/24
172.19.1.1/32172.19.1.1/24
172.19.2.1/32172.19.2.1/24
172.19.3.1/32172.19.3.1/24

 そのため、R3ルータのLoopback0に「172.19.0.1/24」を設定していますが、「172.19.0.1/24」のルートではなく、「172.19.0.1/32」のホストルートをR3ルータはアドバタイズしているのです。Lo1、Lo2、lo3も同様です。

R3ルータで「show ip ospf interface loopback0」コマンドを実行します。

●show ip ospf interface loopback0

R3#show ip ospf interface loopback 0

Loopback0 is up, line protocol is up
  Internet address is 172.19.0.1/24, Area 0
  Process ID 1, Router ID 172.19.3.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

ネットワークタイプに注目します。

「LOOPBACK」となっています。

 ネットワークタイプを POINT-TO-POINT に変更することで、ホストルートではなく、設定されいてるサブネットマスク「/24」でルート情報をアドバタイズさせることができます。

 経路集約や Connected のルートを再配送させる方法もありますが、ネットワークタイプを POINT-TO-POINT に変更する方法が、設定がシンプルでお勧めです。

R3ルータでループバックインターフェイスを POINT-TO-POINT に変更します。

以下の追加の設定を行います。

●R3の追加のコンフィグ

R3(config)#int loopback0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#int loopback1
R3(config-if)#ip ospf network point-to-point
R3(config-if)#int loopback2
R3(config-if)#ip ospf network point-to-point
R3(config-if)#int loopback3
R3(config-if)#ip ospf network point-to-point
R3(config-if)#end
R3#copy run start

ルーティングテーブルの確認

各ルータのルーティングテーブルの内容を確認します。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/1
L       172.17.0.1/32 is directly connected, GigabitEthernet0/1
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:08, GigabitEthernet0/1
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:05, GigabitEthernet0/1
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.0.0/24 is directly connected, Loopback0
L       192.168.0.1/32 is directly connected, Loopback0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Loopback1
L       192.168.1.1/32 is directly connected, Loopback1
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.0/24 is directly connected, Loopback2
L       192.168.2.1/32 is directly connected, Loopback2
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.0/24 is directly connected, Loopback3
L       192.168.3.1/32 is directly connected, Loopback3

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
     172.19.0.0/24 is subnetted, 4 subnets
O       172.19.0.0/24 [110/2] via 172.18.0.2, 00:00:16, GigabitEthernet0/1
O       172.19.1.0/24 [110/2] via 172.18.0.2, 00:00:16, GigabitEthernet0/1
O       172.19.2.0/24 [110/2] via 172.18.0.2, 00:00:16, GigabitEthernet0/1
O       172.19.3.0/24 [110/2] via 172.18.0.2, 00:00:16, GigabitEthernet0/1
R    192.168.0.0/24 [120/1] via 172.17.0.1, 00:00:09, GigabitEthernet0/0
R    192.168.1.0/24 [120/1] via 172.17.0.1, 00:00:09, GigabitEthernet0/0
R    192.168.2.0/24 [120/1] via 172.17.0.1, 00:00:09, GigabitEthernet0/0
R    192.168.3.0/24 [120/1] via 172.17.0.1, 00:00:09, GigabitEthernet0/0

 R3ルータのループバックインターフェイスに設定したネットワークアドレスがR2ルータのルーティングテーブルに反映されていることが確認できます。

●R3ルータのルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 172.17.0.0/16 [110/100] via 172.18.0.1, 00:02:14, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.2/32 is directly connected, GigabitEthernet0/0
     172.19.0.0/16 is variably subnetted, 8 subnets, 2 masks
C       172.19.0.0/24 is directly connected, Loopback0
L       172.19.0.1/32 is directly connected, Loopback0
C       172.19.1.0/24 is directly connected, Loopback1
L       172.19.1.1/32 is directly connected, Loopback1
C       172.19.2.0/24 is directly connected, Loopback2
L       172.19.2.1/32 is directly connected, Loopback2
C       172.19.3.0/24 is directly connected, Loopback3
L       172.19.3.1/32 is directly connected, Loopback3
O E2 192.168.0.0/24 [110/100] via 172.18.0.1, 00:02:14, GigabitEthernet0/0
O E2 192.168.1.0/24 [110/100] via 172.18.0.1, 00:02:14, GigabitEthernet0/0
O E2 192.168.2.0/24 [110/100] via 172.18.0.1, 00:02:14, GigabitEthernet0/0
O E2 192.168.3.0/24 [110/100] via 172.18.0.1, 00:02:14, GigabitEthernet0/0

 RIPネットワークのルートが登録されています。「E2」とマークされていることからOSPFの外部ルートであることが分かります。また、シードメトリック値が「100」でルート情報がアドバタイズされたことが確認できます。

まとめ

 ループバックインターフェイスが所属するネットワークアドレスも実インターフェイスが所属するネットワークアドレスと同様に、ルーティングプロトコルによって伝播させることができます。

 規模の大きなネットワークを演習する場合、ループバックインターフェイスを活用する場面が増えてくるでしょう。

関連コンテンツ