このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ファイルは Packet tracer Version 8.2.0 で作成しています。古いバージョンの Packet Tracer では、ファイルを開くことができませんので、最新の Packet Tracer を準備してください。
 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

マルチエリアOSPF(ABRの設定例)

 ここでは、簡単なマルチエリアでOSPFネットワークを構築していきます。マルチエリア構成では、必ずエリア0が必要になります。R2ルータを下図のように、エリア0とエリア1を接続するABRとして設定し、異なるエリア間で通信ができるようにします。

基本設定

 まずは、基本設定から行います。R1ルータはOSPFのエリア0の設定を、R3ルータはOSPFのエリア1の設定を行います。R2ルータのOSPFの設定は、後から行っていきます。

●R1のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip address 172.19.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#int g0/1
R1(config-if)#ip address 172.20.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#router ospf 1
R1(config-router)#passive-interface g0/0
R1(config-router)#network 172.19.0.0 0.0.255.255 area 0
R1(config-router)#network 172.20.0.0 0.0.255.255 area 0
R1(config-router)#end
R1#copy run start

●R2のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R2
R2(config)#int g0/0
R2(config-if)#ip address 172.20.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#int g0/1
R2(config-if)#ip address 172.21.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-router)#end
R2#copy run start

●R3のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R3
R3(config)#int g0/0
R3(config-if)#ip address 172.21.0.2 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#int g0/1
R3(config-if)#ip address 172.22.0.1 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#router ospf 1
R3(config-router)#passive-interface g0/1
R3(config-router)#network 172.21.0.0 0.0.255.255 area 1
R3(config-router)#network 172.22.0.0 0.0.255.255 area 1
R3(config-router)#end
R3#copy run start

ABRルータの設定

R2ルータでOSPFのエリア0、エリア1の設定を行います。

OSPFを動作させるには、グローバルコンフィギュレーションモードで「router ospf」コマンドを入力します。

Router(config)#router ospf {プロセス番号}
Router(config-router)#network {network} {wildcard} area 0
Router(config-router)#network {network} {wildcard} area {area-id}

プロセス番号: 1~65535

 ABRは、バックボーンエリアと接続するわけですから、networkコマンドで、「area 0」の指定が必須となります。後は、接続するエリアを追加していくだけです。

 プロセス番号は、OSPFプロセスを管理する番号で、各ルータで合わせておく必要はありません。プロセス番号は、OSPFプロセスを管理するためのものです。IGRPやEIGRPのAS番号とは違います。また、エリア番号と合わせる要もありません。

R2ルータは、エリア0とエリア1の両方のトポロジデータベースを構築し、エリア間の通信を行います。

R2ルータのOSPFの設定

R2(config)#router ospf 1
R2(config-router)#network 172.20.0.0 0.0.255.255 area 0
R2(config-router)#network 172.21.0.0 0.0.255.255 area 1

ルーティングテーブルの確認

各ルータのルーティングテーブルを確認します。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.19.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.19.0.0/16 is directly connected, GigabitEthernet0/0
L       172.19.0.1/32 is directly connected, GigabitEthernet0/0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.0.0/16 is directly connected, GigabitEthernet0/1
L       172.20.0.1/32 is directly connected, GigabitEthernet0/1
O IA 172.21.0.0/16 [110/2] via 172.20.0.2, 00:00:55, GigabitEthernet0/1
O IA 172.22.0.0/16 [110/3] via 172.20.0.2, 00:00:55, GigabitEthernet0/1

 黄色のマークのルートはOSPFによるルートです。「IA」と表示されていることから、他エリアの経路情報であることが分かります。

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O    172.19.0.0/16 [110/2] via 172.20.0.1, 00:22:54, GigabitEthernet0/0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.0.0/16 is directly connected, GigabitEthernet0/0
L       172.20.0.2/32 is directly connected, GigabitEthernet0/0
     172.21.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.21.0.0/16 is directly connected, GigabitEthernet0/1
L       172.21.0.1/32 is directly connected, GigabitEthernet0/1
O    172.22.0.0/16 [110/2] via 172.21.0.2, 00:22:59, GigabitEthernet0/1

黄色のマークからエリア0のネットワークを学習していることが確認できます。 

●R3ルータのルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O IA 172.19.0.0/16 [110/3] via 172.21.0.1, 00:26:12, GigabitEthernet0/0
O IA 172.20.0.0/16 [110/2] via 172.21.0.1, 00:26:12, GigabitEthernet0/0
     172.21.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.21.0.0/16 is directly connected, GigabitEthernet0/0
L       172.21.0.2/32 is directly connected, GigabitEthernet0/0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.22.0.0/16 is directly connected, GigabitEthernet0/1
L       172.22.0.1/32 is directly connected, GigabitEthernet0/1

 黄色のマークのルートはOSPFによるルートです。「IA」と表示されていることから、他エリアの経路情報であることが分かります。

ABRであることの確認

 R2ルータでどのタイプのOSPFルータを担当しているかを確認します。確認には「show ip ospf」コマンドを使用します。

R2#show ip ospf

●R2ルータの「show ip ospf」の出力

R2#show ip ospf
 Routing Process "ospf 1" with ID 172.21.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 5. Checksum Sum 0x011a2a
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 5. Checksum Sum 0x014e03
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

黄色のマークから、R2ルータは、ABRであることが分かります。

 次の「マルチエリアOSPF(ABR・ASBR混在設定例①:R1~R3)」では、ABR、ASBRの設定を行い、複数のエリア間、非OSPFネットワーク間の接続を行うネットワークを構築します。