このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習ファイルのダウンロード

 ファイルは Packet tracer Version 8.2.0 で作成しています。古いバージョンの Packet Tracer では、ファイルを開くことができませんので、最新の Packet Tracer を準備してください。
 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

マルチエリアOSPF(ASBRの設定例)

ここでは、RIPとOSPFにおけるルート再配送を例に、ASBRの設定を解説していきます。

 ASBRは、他のASや、OSPF以外のルーティングプロトコルを使用している非OSPFネットワークへ接続しているインターフェイスを持つルータです。ASBRでは、再配送の設定が必要になってきます。

ルートの再配送に関しては以下のコンテンツを参考にしてみて下さい。

ここでは、以下のネットワークを構築します。

 下図のネットワーク構成図は、マルチエリアOSPF構成ではありません。ASBRは、マルチエリア構成時に非OSPFネットワークへ接続するためルータであるとは限りません。シングルエリアOSPFと非OSPFネットワークを接続する際のルータもASBRといいます。

 ASBRは、OSPFネットワークと非OSPFネットワークの接続ポイントです。トラフィックの交差点になります。また、負荷のかかるOSPFの実行や再配送の処理も行います。なるべく高性能なルータを使用し、多くのOSPFエリアとの接続や、ABRや他のASBRを兼任させないような配慮が必要です。

ASBRは、非OSPFネットワークのルート情報をLSAタイプ5(AS外部LSA)でOSPFネットワークへ通知します。

基本設定

 まずは、基本設定から行っていきます。R1ルータはRIPの設定を、R3ルータはOSPFの設定を行います。R2ルータのルーティングプロトコルの設定は、後から行います。

●R1のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip address 172.16.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#int g0/1
R1(config-if)#ip address 172.17.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#router rip
R1(config-router)#passive-interface g0/0
R1(config-router)#network 172.16.0.0
R1(config-router)#network 172.17.0.0
R1(config-router)#end
R1#copy run start

●R2のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R2
R2(config)#int g0/0
R2(config-if)#ip address 172.17.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#int g0/1
R2(config-if)#ip address 172.18.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-router)#end
R2#copy run start

●R3のコンフィグ

Router>enable
Router#conf t
Router(config)#hostname R3
R3(config)#int g0/0
R3(config-if)#ip address 172.18.0.2 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#int g0/1
R3(config-if)#ip address 172.19.0.1 255.255.0.0
R3(config-if)#no shutdown
R3(config-if)#router ospf 1
R3(config-router)#passive-interface g0/1
R3(config-router)#network 172.18.0.0 0.0.255.255 area 0
R3(config-router)#network 172.19.0.0 0.0.255.255 area 0
R3(config-router)#end
R3#copy run start

RIPとOSPFにおける再配送の設定

 ルーティングプロトコルによってメトリックが異なるため、互換性がありません。そこで、管理者がルート再配送を行う際に、メトリックを調整するわけです。シードメトリックの設定を省略するとデフォルトのシードメトリック値が使われることになります。

シードメトリックのデフォルト値は以下の表のようになっています。

シード メトリックのデフォルト値
ルート再配送先のルーティングプロトコルシードメトリックのデフォルト値
RIP無限大
IGRP/EIGRP無限大
OSPF20、BGPの場合は1

 RIPのデフォルトのシードメトリック値は、無限大になっています。つまり、シードメトリック値の指定を忘れてしまうと到達不能のルートとして扱われてしまいます。

そこで、R2ルータで再配布を設定する際に、シードメトリック値を指定します。

R2ルータの再配送の設定

R2ルータでRIPルート、OSPFルートを再配送する設定を行います。

RIPルートの再配送

RIPで学習したルートをOSPFへ再配送するように以下のように設定します。
※設定を省略した場合でも、デフォルトのシードメトリック値である「20」が使われるため、再配送は行われます。

R2(config)#router ospf 1
R2(config-router)#redistribute rip metric 100 subnets
R2(config-router)#network 172.18.0.0 0.0.255.255 area 0

 「redistribute rip metric 100 subnets」と指定することで、シードメトリック値に「100」を設定しています。「subnets」は、クラスレスルートを再配送させるためのオプションです。このオプションを指定することで、サブネット化された経路情報を再配送できるようになります。

OSPFネットワークへ再配送する際には、「subnets」を指定しておきます。

OSPFルートの再配送

OSPFで学習したルートをRIPへ再配送するように以下のように設定します。

R2(config)#router rip
R2(config-rouiter)#redistribute ospf 1 metric 10
R2(config-router)#network 172.17.0.0

「redistribute ospf 1 metric 10」と指定することで、シードメトリック値を「10」に設定します。

ルーティングテーブルの確認

各ルータのルーティングテーブルを確認します。

●R1ルータのルーティングテーブル

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.0.0/16 is directly connected, GigabitEthernet0/0
L       172.16.0.1/32 is directly connected, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/1
L       172.17.0.1/32 is directly connected, GigabitEthernet0/1
R    172.18.0.0/16 [120/10] via 172.17.0.2, 00:00:10, GigabitEthernet0/1
R    172.19.0.0/16 [120/10] via 172.17.0.2, 00:00:10, GigabitEthernet0/1

 RIPのエントリーが2つ現れています。これは、デフォルトの無限大のシードメトリックではなく、「10」が使われたことがわかります。

●R2ルータのルーティングテーブル

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:23, GigabitEthernet0/0
     172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.17.0.0/16 is directly connected, GigabitEthernet0/0
L       172.17.0.2/32 is directly connected, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/1
L       172.18.0.1/32 is directly connected, GigabitEthernet0/1
O    172.19.0.0/16 [110/2] via 172.18.0.2, 00:07:45, GigabitEthernet0/1

●R3ルータのルーティングテーブル

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 172.16.0.0/16 [110/100] via 172.18.0.1, 00:13:34, GigabitEthernet0/0
O E2 172.17.0.0/16 [110/100] via 172.18.0.1, 00:13:34, GigabitEthernet0/0
     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.0.0/16 is directly connected, GigabitEthernet0/0
L       172.18.0.2/32 is directly connected, GigabitEthernet0/0
     172.19.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.19.0.0/16 is directly connected, GigabitEthernet0/1
L       172.19.0.1/32 is directly connected, GigabitEthernet0/1

 RIPネットワークの「172.16.0.0」、「172.17.0.0」が登録されています。「E2」とマークされていることからOSPFの外部ルートであることが分かります。また、シードメトリック値が「100」でルート情報をアドバタイズしていることが確認できます。

ASBRであることの確認

 R2ルータがどのタイプのOSPFルータを担当しているかを確認します。確認には「show ip ospf」コマンドを使用します。

Router#show ip ospf

●R2ルータの「show ip ospf」の出力

R2#show ip ospf
 Routing Process "ospf 1" with ID 172.18.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an autonomous system boundary router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 2. Checksum Sum 0x017075
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 2 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x011fa6
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

黄色のマークから、R2ルータがASBRであることが分かります。

 次の「マルチエリアOSPF(ABRの設定例)」では、ABRの設定を行い、複数のOSPFエリアを接続するネットワークを構築します。