サイト間VPN(その1)

SDMでは、次のVPNが設定できるようになっています。

  • サイト間VPN
  • Easy VPNリモート
  • Easy VPNサーバ
  • ダイナミック マルチポイントVPN
  • SSL VPN

ここでは、SDMを使用して、サイト間VPNの設定を行っていきます。

※サイト間VPNは、IOSが対応していなければ、設定することはできません。

 VPNとは、インターネットを経由して構築される仮想的なプライベートネットワークのことです。このVPNを経由することによって、離れた拠点のLAN同士を、インターネット経由することによって、まるでLANで接続しているかのように接続することができます。

 インターネットは、不特定多数の人が利用する公衆回線です。インターネット上に流れるデータは、盗聴される恐れがあります。そこで、インターネットVPNでは、IPsecを使用して、通信内容の暗号化を行い、機密性の高いデータを通信を可能にしています。

その為、機密を保持したまま、遠隔地のネットワーク同士をLANを接続することができます。

 VPNの接続は、初心者にとって少々敷居の高い設定となるのですが、SDMを使用するとウィザード形式で、指示に従うことで簡単にVPNを設定することができます。

それでは、以下のネットワーク構成で、VPNを設定していきます。

SDMでルータを設定できるようにする

まずは、Router_A、Router_BをSDMで設定できるように設定していきます。

●Router_A

PC_A上からRouter_AをSDMで操作できるように設定します。

この作業は、CLIで行う必要があります。

Routerのグローバル設定モードから下の設定を流し込みます。

interface f0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username cisco privilege 15 password 0 cisco
line vty 0 4
privilege level 15
login local
transport input telnet
exit

※ユーザアカウントは、ルータへ接続時に変更するように求められます。ここでは、ユーザ名に「ccnaccnp」をパスワードに「ccnaccnp」を設定するものとして、説明していきます。

これで、PC_A上からSDMでRouter_Aを管理できるようになります。

●Router_B

PC_B上からRouter_BをSDMで操作できるように設定します。

この作業は、CLIで行う必要があります。

Routerのグローバル設定モードから下の設定を流し込みます。

interface f0
ip address 192.168.2.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username cisco privilege 15 password 0 cisco
line vty 0 4
privilege level 15
login local
transport input telnet
exit

※ユーザアカウントは、ルータへ接続時に変更するように求められます。ここでは、ユーザ名に「ccnaccnp」をパスワードに「ccnaccnp」を設定するものとして、説明していきます。

これで、PC_B上からSDMでRouter_Bを管理できるようになります。

基本設定

インターフェースへのIPアドレスの割り当て、ルータ名の変更は、省略します。

インターフェイスの設定(その1)
ルータの名前を変更する(hostname)

を参考にして下さい。

下準備ができたところで、VPNを設定していきます。

まずは、Router_A、Router_Bにデフォルトルートを設定していきます。

続きは、次の「サイト間VPN(その2)」で行います。

関連コンテンツ