このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

演習ファイルのダウンロード

NAT(PAT オーバーローディング)

 「PAT(オーバーローディング)」は、TCP/UDPのポートを管理することで1つのグローバルIPアドレスでローカルIPアドレスが設定された複数の端末を同時に通信できるようにします。

ここでは、PAT(オーバーローディング)の設定を解説していきます。ネットワーク構成は、下図のとおりです。

基本設定

まず、各ルータのホスト名とIPv4アドレスなどの基本設定を行います。

各ルータの基本コンフィグは、以下のとおりです。

●R1のコンフィグ
hostname R1
ip route 0.0.0.0 0.0.0.0 10.0.0.2
int g0/0
ip address 172.16.0.1 255.255.255.0
no shutdown
int s0/0/0
ip address 10.0.0.1 255.255.255.0
clock rate 64000
bandwidth 64
no shutdown
end
copy run start

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 10.0.0.2 255.255.255.0
bandwidth 64
no shutdown
int lo0
ip address 20.0.0.1 255.255.255.0
int lo1
ip address 30.0.0.1 255.255.255.0
int lo2
ip address 40.0.0.1 255.255.255.0
int lo3
ip address 50.0.0.1 255.255.255.0
end
copy run start

PAT(オーバーローディング)の設定

R1ルータの Serial00/0 インターフェイスに割り当てられているIPv4アドレスをオーバーロードさせます。

●アクセスリストの設定

 「ip nat pool」コマンドで指定した内部グローバルアドレスを使用することを許可する送信元アドレスをアクセスリストで指定します。

Router(config)#access-list {番号} permit {送信元IPアドレス} {ワイルドカードマスク}

●PATとアクセスリストをマッピングする

 「overload」キーワードでRouterのインターフェイスに割り当てられた内部グローバルアドレスをオーバーロードさせます。

Router(config)#ip nat inside source list {番号} interface {インタフェース名} overload

●内部ローカルネットワークの設定

 LAN側に接続されているルータのインタフェースに、「ip nat inside」コマンドを使ってスタティックNATを有効にします。

Router(config-if)#ip nat inside

●内部グローバルネットワークの設定

 インターネット側に接続されているルータのインタフェースに、「ip nat outside」コマンドを使ってスタティックNATを有効にします。

Router(config-if)#ip nat outside

各ルータの設定

R1ルータで以下の設定を行います。

●R1ルータ

R1(config)#access-list 1 permit 172.16.0.0 0.0.0.255
R1(config)#ip nat inside source list 1 interface serial 0/0/0

R1(config)#int g0/0
R1(config-if)#ip nat inside

R1(config)#int s0/0/0
R1(config-if)#ip nat outside

NATテーブルの確認

現在のNATテーブルを確認するには「show ip nat translations」コマンドを使います。

Router#show ip nat translations

それでは、NATテーブルを確認するために、PC1、PC2から、インターネット網の「20.0.0.1」へPingを行います。

●PC1からのPing

C:>ping 20.0.0.1

●PC2からのPing

C:>ping 20.0.0.1

NATテーブルの確認

R1ルータで「show ip nat translations」コマンドを入力します。

●「show ip nat translations」コマンドの出力

R1#show ip nat translations 
Pro  Inside global     Inside local       Outside local      Outside global
icmp 10.0.0.1:1024     172.16.0.20:1      20.0.0.1:1         20.0.0.1:1024
icmp 10.0.0.1:1025     172.16.0.20:2      20.0.0.1:2         20.0.0.1:1025
icmp 10.0.0.1:1026     172.16.0.20:3      20.0.0.1:3         20.0.0.1:1026
icmp 10.0.0.1:1027     172.16.0.20:4      20.0.0.1:4         20.0.0.1:1027
icmp 10.0.0.1:1        172.16.0.10:1      20.0.0.1:1         20.0.0.1:1
icmp 10.0.0.1:2        172.16.0.10:2      20.0.0.1:2         20.0.0.1:2
icmp 10.0.0.1:3        172.16.0.10:3      20.0.0.1:3         20.0.0.1:3
icmp 10.0.0.1:4        172.16.0.10:4      20.0.0.1:4         20.0.0.1:4

 TCP/UDPのポートを管理することで1つの内部グローバルアドレスをオーバーロードして通信していることが分かります。

次の「NATの検証コマンド」では、NATの検証コマンドを紹介します。

関連コンテンツ

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。