URLフィルタリング・部分ドメインの指定(その2)

URLフィルタリング・部分ドメインの指定(その2)」の続きです。

URLフィルタリング(その1)」~「URLフィルタリング(その8)」でRouter_Aに設定した内容を変更してゆきます。

ネットワークの構成は、下図の通りです。

※ブロードバンドルータには、IPマスカレードの設定をしておきます。

◆URLリストの編集

「goo」と「Yahoo!」のURLリストを編集します。

 管理人が使用するバージョンのSDMでは、一度、設定したURLを編集することができないので、「goo」と「Yahoo!」のURLリストを削除します。

上メニューの「設定」をクリックし、左メニューの「追加タスク」をクリックします。

「URL フィルタリング」を展開し、「ローカル URLリスト」を選択し、「すべて削除」ボタンをクリックします。

「SDM警告」が表示されます。「はい」をクリックします。

次に、部分ドメイン「.goo.ne.jp」、「.yahoo.co.jp」をURLリストに追加します。

「追加」ボタンをクリックします。

「.goo.ne.jp」を拒否するように追加します。

「.yahoo.co.jp」を拒否するように追加します。

これで、編集は完了です。

「.goo.ne.jp」には、「goo」、「goo 辞書」がマッチすることになります。
「.yahoo.co.jp」には、「Yahoo!」、「Yahoo!きっず」がマッチすることになります。

部分ドメイン指定のURLフィルタリングの検証

ブラウザを起動して、「goo」、「goo 辞書」、「Yahoo!」、「Yahoo!きっず」の全てのサイトにアクセスしてみます。

すると全てのサイトにアクセスできないことが確認できます。

●Router_Aの設定

!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 25
!
ip cef
ip inspect name URL_FILTER http urlfilter
ip urlfilter allow-mode on
ip urlfilter exclusive-domain deny .goo.ne.jp
ip urlfilter exclusive-domain deny .yahoo.co.jp
!
crypto pki trustpoint TP-self-signed-2739943660
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2739943660
 revocation-check none
 rsakeypair TP-self-signed-2739943660
!
crypto pki certificate chain TP-self-signed-2739943660
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32373339 39343336 3630301E 170D3032 30333031 30383332
  31385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37333939
  34333636 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BCC7 ADC3FBAC C46E09CA A34DE8C0 2119F31A 8BDBC53C C337FB5D 8CF51076
  8A648F70 CF81F4E2 DD5B849C 9CE8B2BD E0BC1B92 B61185AC E5209FED 955D72F3
  5662DA31 F956C72B 7BA9AB72 5002F145 AEE39E6E E1A25B27 C840394F 131F6BC8
  A3F8C495 4F820841 C2BA58AF F8626E25 FC44B3C6 5E57C041 DAA02EF1 685322AD
  D6BD0203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 08526F75 7465725F 41301F06 03551D23 04183016 80149D42
  147E08D7 AECD0824 17C020C2 5193A8D6 CFDD301D 0603551D 0E041604 149D4214
  7E08D7AE CD082417 C020C251 93A8D6CF DD300D06 092A8648 86F70D01 01040500
  03818100 88009E92 0F0FF7C3 8AE7C021 F639C2D5 A06C4257 05A45159 10282281
  F70FA092 8E0BB203 D823E795 EE1A208E 9480184E 97AAE0CD 4645FC9D F69FEC91
  AD6EF5D9 A6989F39 9D4E1EA1 D061B6B8 4967378E 126EAA5A EA480DD0 32EC7B06
  CEF0798D 82CBEA5D 63A0F2F2 35C9BFDE A6860936 707296CB 07474B4B 75321D2B A11FBA5D
  quit
username ccnaccnp privilege 15 secret 5 ccnaccnp
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 half-duplex
!
interface FastEthernet0
 ip address 192.168.2.1 255.255.255.0
 ip inspect URL_FILTER in
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip http server
ip http authentication local
ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
!
end

 このように部分ドメイン名をうまく指定することで、URLリストの数を減らすことができます。

関連コンテンツ