このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

演習で学ぶネットワーク:3拠点のVPN接続(本社:拠点A-支社:拠点C) - YouTube

3拠点をVPNで接続するネットワークの設定を解説していきます。 このPartでは、本社の拠点Aと、支社の拠点CをVPNで接続する設定を行い、3拠点をVPNで接続するネットワーク…

3拠点のVPN接続(本社:拠点A-支社:拠点C)

ここでは、「本社:拠点A-支社:拠点C」間のネットワークを設定していきます。

「本社:拠点A-支社:拠点C」間は、VPNで接続します。

「本社:拠点A-支社:拠点C」間のネットワーク設定

下の赤枠の「本社:拠点A-支社:拠点C」間のネットワークを設定していきます。VPNの設定も行います。

●R4ルータ

enable
conf t
access-list 100 permit ip 10.0.0.0 0.255.255.255 10.5.0.0 0.0.255.255
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash sha
exit
crypto isakmp key cisco address 201.200.200.2
crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
crypto map MAP-IPSEC 1 ipsec-isakmp
match address 100
set peer 201.200.200.2
set transform-set TS-IPSEC
set security-association lifetime seconds 3600
interface f0/1
crypto map MAP-IPSEC
end
copy run start

●R5ルータ

↓基本設定
enable
conf t
hostname R5
ip route 0.0.0.0 0.0.0.0 201.200.200.1
int f0/0
ip address 10.5.0.1 255.255.0.0
no shutdown
int f0/1
ip address 201.200.200.2 255.255.255.0
no shutdown
exit

↓VPNの設定
access-list 100 permit ip 10.5.0.0 0.0.255.255 10.0.0.0 0.255.255.255
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash sha
exit
crypto isakmp key cisco address 201.200.200.1
crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
crypto map MAP-IPSEC 1 ipsec-isakmp
match address 100
set peer 201.200.200.1
set transform-set TS-IPSEC
set security-association lifetime seconds 3600
interface f0/1
crypto map MAP-IPSEC
end
copy run start

疎通確認

拠点A-拠点C間の疎通確認

PC1からPC3のIPアドレス「10.5.0.2」に対してpingを実行します。

C:>ping 10.5.0.2

pingは4度目の試行で成功しています。

カプセル化の確認

まず、拠点A-拠点C間に流れるパケットのカプセル化を確認します。

●シミュレーションモードに切り替えます。

・シミュレーションボタンをクリックします。

・PC1からPC3のIPアドレス「10.5.0.2」に対してpingを実行します。

C:>ping 10.5.0.2

PC1上に封筒が現れます。

・「Play Controls」の「▶|」ボタンをクリックします。

時間が1ステップ進みます。封筒がR4ルータに到達するまで、クリックします。

・R4ルータ上の封筒をクリックします。

・「Outbound PDU Details」タブをクリックします。

「ESP」ヘッダーでカプセル化されていることが確認できます。VPNで通信が行われていることが確認できます。

●リアルタイム・モードに切り替えます。

PC1からPC2へのpingを完了させます。

・「Realtime」ボタンをクリックします。

構築した3拠点をVPNで接続したネットワークは、次の「3拠点のVPN接続の検証」で検証していきます。

関連コンテンツ