このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

演習ファイルのダウンロード

PPPの設定(encapsulation ppp)

Serial のカプセル化の指定をPPPに設定するには、「encapsulation ppp」コマンドを使います。

Router(config-if)#encapsulation ppp

 PPP では、認証方法として、PAP と CHAP を選択できますが、認証が必要なければ、認証の設定は省略できます。PPP の認証の設定は、次のコンテンツで紹介します。

認証方式特徴
PAP・クリアテキストでパスワードを交換する。
・認証は、初めの1回のみ。
CHAP・暗号化したパスワードを交換。
・定期的に毎回違う文字列で認証を行う。

それでは、下のネットワークを RIP で構築し Serial リンクを PPP でカプセル化を行っていきます。

基本設定

まず、各ルータのホスト名とIPv4アドレス、RIPv2 などの基本設定を行います。

各ルータの基本コンフィグは、以下のとおりです。

●R1のコンフィグ
hostname R1
int g0/0
ip address 172.16.0.1 255.255.0.0
no shutdown
int s0/0/0
ip address 172.17.0.1 255.255.0.0
clock rate 64000
bandwidth 64
no shutdown
exit
router rip
version 2
network 172.16.0.0
network 172.17.0.0
end
copy run start

●R2のコンフィグ
hostname R2
int s0/0/0
ip address 172.17.0.2 255.255.0.0
bandwidth 64
no shutdown
int g0/0
ip address 172.18.0.1 255.255.0.0
no shutdown
exit
router rip
version 2
network 172.17.0.0
network 172.18.0.0
end
copy run start

Serial のデータリンク層のカプセル化の確認

Serial のデータリンク層のカプセル化を確認します。

R1ルータで、「show int s0/0/0」コマンドを入力します。

R1#show int s0/0/0
Serial0/0/0 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 172.17.0.1/16
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 15 bits/sec, 0 packets/sec
  5 minute output rate 13 bits/sec, 0 packets/sec
     17 packets input, 884 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     16 packets output, 832 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

黄色のマークの「line protocol is up」から、データリンク層が、UPしていることを確認できます。

R2ルータで、「show int s0/0/0」コマンドを入力します。

R2#show int s0/0/0
Serial0/0/0 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 172.17.0.2/16
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 15 bits/sec, 0 packets/sec
  5 minute output rate 15 bits/sec, 0 packets/sec
     38 packets input, 1976 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     38 packets output, 1976 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

 R1ルータ、R2ルータの出力の「Encapsulation HDLC」から、両ルータの Serial のカプセル化は、Cisco HDLC であることが分かります。

PPPの設定

 Serialのデフォルトのカプセル化は、Cisco HDLC です。R1ルータ、R2ルータのそれぞれのルータの Serial で PPP を指定します。

●R1ルータにて

まず、R1ルータで「PPP」のカプセル化を行います。

R1(config)#int s0/0/0
R1(config-if)#encapsulation ppp

下の黄色のマークのメッセージが表示され、リンクが DOWN したことが分かります。

R1(config-if)#encapsulation ppp
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

Serial のデータリンク層のカプセル化を確認します。

R1#show int s0/0/0
Serial0/0/0 is up, line protocol is down (disabled)
  Hardware is HD64570
  Internet address is 172.17.0.1/16
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  LCP Closed
  Closed: LEXCP, BRIDGECP, IPCP, CCP, CDPCP, LLC2, BACP
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 4 bits/sec, 0 packets/sec
  5 minute output rate 5 bits/sec, 0 packets/sec
     80 packets input, 4160 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     79 packets output, 4108 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

 水色のマーカーから、R1ルータのSerialのカプセル化が「PPP」であること、先ほど確認したように、R2ルータのSerialのカプセル化は「Cisco HDLC」です。カプセル化が不一致とが起きています。

 黄色のマークは、以下のようになっており、物理層はUPしており、データリンク層がDOWNしています。つまり、両ルータ間のSerialリンクで、カプセル化が不一致とが起きています。

Serial0/0/0 is up, line protocol is down (disabled)

物理層は、UPしているため、下図のようにリンクライトは、緑色になっています。

PC1から、PC2へPingを行ってみます。

もちろん、Pingは失敗します。

●R2ルータにて

R2(config)#int s0/0/0
R2(config-if)#encapsulation ppp

下の黄色のマークのメッセージが表示され、リンクが UP したことが分かります。

R2(config-if)#encapsulation ppp
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

 両ルータ間の Serial リンクで、カプセル化の指定が「PPP」となり、カプセル化が一致したため、Serial リンクがUPします。

疎通確認

PC1から、PC2へPingを行います。

もちろん、Pingは成功します。

次の「PPP認証(ppp atuthentication pap)」では、PPP の PAP認証について解説します。

関連コンテンツ

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。