外部経路による経路導入RIP→OSPF

ここでは、外部経路による経路導入を紹介していきます。

ネットワーク構成は、下図の通りです。

OSPFにRIPで学習した経路を導入します。

検証に使用したルータは、以下の通りです。

RAルータ・・・Cisco1710
RBルータ・・・YAMAHA RTX1000
RCルータ・・・YAMAHA RTX1000

まずは、経路導入の設定以外を行います。

各ルータのルーティングプロトコルは、以下の通りです。

RAルータ・・・RIP
RBルータ・・・RIP、OSPF
RCルータ・・・OSPF

●RAの設定

!
interface Loopback0
 ip address 10.0.0.1 255.0.0.0
!
interface Loopback1
 ip address 20.0.0.1 255.0.0.0
!
interface Loopback2
 ip address 30.0.0.1 255.0.0.0
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
router rip
 network 10.0.0.0
 network 20.0.0.0
 network 30.0.0.0
 network 192.168.1.0
!

●RBの設定

console prompt RB
ip lan1 address 192.168.1.2/24
ip lan2 address 192.168.2.1/24
ip lan2 ospf area backbone
rip use on
ospf use on
ospf area backbone
ospf configure refresh

●RCの設定

console prompt RC
ip lan1 address 192.168.3.1/24
ip lan2 address 192.168.2.2/24
ospf use on
ospf area backbone
ip lan1 ospf area backbone
ip lan2 ospf area backbone
ospf configure refresh

ルーティングテーブルの確認

各ルータのルーティングテーブルを確認します。

●RAのルーティングテーブル(Cisco)

C    20.0.0.0/8 is directly connected, Loopback1
C    10.0.0.0/8 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, FastEthernet0
R    192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:08, FastEthernet0
R    192.168.3.0/24 [120/1] via 192.168.1.2, 00:00:08, FastEthernet0
C    30.0.0.0/8 is directly connected, Loopback2

RBでRIPの外部経路導入の設定を行っていないのに「192.168.3.0/24」の経路情報をRIPで学習しています。

 どうやら、RIPでは外部経路導入の設定は行わなくても、自動的に外部経路をRIPに注入するようです。コマンドリファレンスを見ても、RIPの外部経路導入のコマンドは見当たりません。

●RBのルーティングテーブル(YAMAHA)

RB# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
10.0.0.0/8          192.168.1.1            LAN1       RIP  metric=1
20.0.0.0/8          192.168.1.1            LAN1       RIP  metric=1
30.0.0.0/8          192.168.1.1            LAN1       RIP  metric=1
192.168.1.0/24      192.168.1.2            LAN1  implicit
192.168.2.0/24      192.168.2.1            LAN2  implicit
192.168.3.0/24      192.168.2.2            LAN2      OSPF     cost=2

●RCのルーティングテーブル(YAMAHA)

RC# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
192.168.2.0/24      192.168.2.2            LAN2  implicit
192.168.3.0/24      192.168.3.1            LAN1  implicit

 RBでOSPFの外部経路導入の設定を行っていないので、「10.0.0.0/8」、「20.0.0.0/8」、「20.0.0.0/8」の経路情報がありません。

RIP経路をOSPFネットワークに導入(注入)する

ここからは、下図のようにRIP経路をOSPFネットワークに導入(注入)していく設定を行っていきます。

外部プロトコルによる経路導入

 OSPFの経路テーブルに外部プロトコルによる経路を導入するには、以下のコマンドを使用します。導入された経路は、外部経路として他のOSPFルータに広告されます。

ospf import from <protocol>

[設定値及び初期値]

●protocol : OSPF の経路テーブルに導入する外部プロトコル
[設定値] :

設定値説明
static静的経路
ripRIP
bgpBGP

RBルータにて、経路導入の設定を行います。

RB# ospf import from rip
RB# ospf configure refresh

RCルータのルーティングテーブルを確認します。

●RCのルーティングテーブル(YAMAHA)

RC# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
10.0.0.0/8          192.168.2.1            LAN2      OSPF  E2 cost=1 metric=1
20.0.0.0/8          192.168.2.1            LAN2      OSPF  E2 cost=1 metric=1
30.0.0.0/8          192.168.2.1            LAN2      OSPF  E2 cost=1 metric=1
192.168.2.0/24      192.168.2.2            LAN2  implicit
192.168.3.0/24      192.168.3.1            LAN1  implicit

 RBでOSPFの外部経路導入の設定を行ったので、「10.0.0.0/8」、「20.0.0.0/8」、「20.0.0.0/8」の経路情報がOSPFネットワークに所属するRCルータに伝搬されていることが確認できます。

しかし、「192.168.1.0/24」の経路情報がありません。

RBルータのルーティングテーブルを確認します。

●RBのルーティングテーブル(YAMAHA)

RB# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
10.0.0.0/8          192.168.1.1            LAN1       RIP  metric=1
20.0.0.0/8          192.168.1.1            LAN1       RIP  metric=1
30.0.0.0/8          192.168.1.1            LAN1       RIP  metric=1
192.168.1.0/24      192.168.1.2            LAN1  implicit
192.168.2.0/24      192.168.2.1            LAN2  implicit
192.168.3.0/24      192.168.2.2            LAN2      OSPF     cost=2

 RBルータがRIPで学習している経路は、「10.0.0.0/8」、「20.0.0.0/8」、「20.0.0.0/8」の経路です。「192.168.1.0/24」の経路情報は、ありません。

 RIPで学習した経路が導入(注入)される訳ですから、RCのルーティングテーブルに「192.168.1.0/24」がないのは、当然なのです。

RBルータに以下のコマンドを追加します。

RB# ip lan1 ospf area backbone
RB# ospf configure refresh

再度、RCルータのルーティングテーブルを確認します。

●RCのルーティングテーブル(YAMAHA)

RC# show ip route
宛先ネットワーク    ゲートウェイ     インタフェース  種別  付加情報
10.0.0.0/8          192.168.2.1            LAN2      OSPF  E2 cost=2 metric=1
20.0.0.0/8          192.168.2.1            LAN2      OSPF  E2 cost=2 metric=1
30.0.0.0/8          192.168.2.1            LAN2      OSPF  E2 cost=2 metric=1
192.168.1.0/24      192.168.2.1            LAN2      OSPF     cost=2
192.168.2.0/24      192.168.2.2            LAN2  implicit
192.168.3.0/24      192.168.3.1            LAN1  implicit

「192.168.1.0/24」の経路情報が追加されています。