このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

コンフィグを転送して設定を復元する

 ここでは、グローバル設定モードから、コンフィグを流し込むことで設定を復元する方法について解説していきます。

設定をテキストエディタで編集する

 RAルータを例に、設定内容を復元する方法を解説していきます。まず、 「show running-config」コマンドで出力したコンフィグを選択コピーして、テキストエディタで編集していきます。

 RAルータで、「show running-config」コマンドを実行して、出力されたコンフィグををコピーして、テキストエディタに貼り付けます。

 テキストエディタで、不要なコマンドや「!」を取り除いて、編集します。コンフィグを読みやすくするために、ある程度、「!」を残しておくのがおすすめです。

インターフェイスの設定のところで、「no shutdown」コマンドを追加しておきます。

 基本的に、コンフィグを転送する際は、あらかじめルータの設定を空にしておきます。現在設定されているコンフィグに転送するコンフィグがマージされるからです。

 ルータの設定が空の場合、インターフェイスはデフォルトで「shutdown」になっています。つまり、インターフェイスは、Downしています。

 転送する設定コンフィグに「no shutdown」コマンドを追加していない場合は、転送後、各インタフェースがdownしたままの状態になっています。

 後から、各インターフェイス設定モードに入って「no shutdown」コマンドを入力するのは面倒なので、「no shutdown」を入れておきます。

編集したコンフィグは、以下の通りです。

●編集したコンフィグ

!
hostname RA
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!
interface Serial0/0/0
 bandwidth 64
 ip address 192.168.3.1 255.255.255.0
 clock rate 64000
 no shutdown
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
!
end

このルータへの設定コンフィグを流し込めば、わざわざ、各々のルータで1つずつコマンドで設定していかなくとも済みます。

設定を復元する

 「no shutdown」コマンドを追加したら転送したい部分を選択して、「Ctrl + C」キーを押してクリップボードにコピーしておきます。

ルータにクリップボードにコピーした内容をルータに流し込みます。

ここが、重要です。

ルータに設定を流し込むには、グローバル設定モードに移行しておく必要があります。

 もし間違えて、違う設定モードでクリップボードの内容をルータに流し込むと、ルータがコマンドが解釈できなかったり、DNSにてコマンド名をホスト名として名前解決しようとして、しばらくの間、ルータは固まってしまいます。

ルータに設定を流し込む際は、必ずグローバル設定モードに移行しているかどうか確認してから行います。

その前に、RAの設定を空にして、再起動させます。

以下のコマンドを実行しておきます。

RA#erase startup-config
RA#reload

それでは、設定をルータに流し込んでいきます。

グローバル設定モードに移行します。

Router(config)#

のプロンプトのところで、「Ctrl + V」キーを押します。クリップボードにコピーしていた内容がルータ上で展開されます。

Router(config)#! ← ここで、コピーペーストを行います 
Router(config)#hostname Router_A
Router_A(config)#!
Router_A(config)#enable password cisco
Router_A(config)#!
Router_A(config)#interface GigabitEthernet0/0
Router_A(config-if)# ip address 172.16.1.1 255.255.255.0
Router_A(config-if)# no shutdown

Router_A(config-if)#!
Router_A(config-if)#interface Serial0/0/0
Router_A(config-if)# ip address 172.16.2.1 255.255.255.0
Router_A(config-if)# clock rate 64000
Router_A(config-if)# no shutdown

Router_A(config-if)#!
Router_A(config-if)#router rip
Router_A(config-router)# network 172.16.0.0
Router_A(config-router)#!
Router_A(config-router)#line vty 0 4
Router_A(config-line)# password cisco
Router_A(config-line)# login
Router_A(config-line)#!
Router_A(config-line)#end
Router_A#!

 このルータへの設定コンフィグを流し込む方法を使えば、わざわざ各ルータで1つずつコマンドで設定しなくて済みます。テキストファイル上でコンフィグの内容を編集することで、ルータの設定時間を短縮することができます。