DHCPリレーエージェントの設定(その1)

ここでは、SDMを使用して、DHCPリレーエージェントの設定を行っていきます。

以下のネットワーク構成で設定を行っていきます。

Router_AでDHCPサーバ機能を有効にし、DHCPサーバとして使用します。

プール名 ・・・ 「POOL1」
プールの範囲 ・・・ 「192.168.3.100 ~ 192.168.3.200」

SDMでルータを設定できるようにする

●Router_A

PC_A上からRouterをSDMで操作できるように設定します。

この作業は、CLIで行う必要があります。

Routerのグローバル設定モードから下の設定を流し込みます。

interface f0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username cisco privilege 15 password 0 cisco
line vty 0 4
privilege level 15
login local
transport input telnet
exit

※ユーザアカウントは、ルータへ接続時に変更するように求められます。ここでは、ユーザ名に「ccnaccnp」をパスワードに「ccnaccnp」を設定するものとして、説明してていきます。

これで、PC_A上からSDMでRouterを管理できるようになります。

●Router_B

PC_B上からRouterをSDMで操作できるように設定します。

この作業は、CLIで行う必要があります。

Routerのグローバル設定モードから下の設定を流し込みます。


interface f0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username cisco privilege 15 password 0 cisco
line vty 0 4
privilege level 15
login local
transport input telnet
exit

※ユーザアカウントは、ルータへ接続時に変更するように求められます。ここでは、ユーザ名に「ccnaccnp」をパスワードに「ccnaccnp」を設定するものとして、説明していきます。

これで、PC_B上からSDMでRouterを管理できるようになります。

※SDMで、Router_Bを設定する際には、一時的にPC_BのIPアドレスは、「192.168.3.2/24」などの固定IPアドレスを割り当てておきます。Router_Bの設定完了時には、IPアドレスを自動取得にします。

Router_Aの設定(DHCPサーバ機能の設定)

Router_AのDHCPサーバ機能を設定していきます。

基本設定

インターフェースへのIPアドレスの割り当て、ルータ名の変更は、省略します。

  • インターフェイスの設定(その1)
  • ルータの名前を変更する(hostname)

を参考にして下さい。

DHCPサーバ機能の設定

「設定」→「追加タスク」をクリックします。

「DHCP」を展開して、「DHCPプール」を選択します。

「DHCPプール」 ウィンドウが表示されます。「追加」をクリックします。

「DHCPプールの追加」が表示されます。

●DHCPプールの設定

・DHCPプール名

DHCPプール名とは、IPの払い出しの設定ごとに付ける名前です。ここでは、「POOL1」と名付けることにします。

・DHCPプールのネットワーク

払い出しをするIPアドレスのネットワークアドレスを入力します。ここでは、「192.168.3.0」としています。

・サブネットマスク

払い出しをするIPアドレスのサブネットマスクを入力します。ここでは、「255.255.255.0」としています。

・DHCPプール

払い出しをするIPアドレスの範囲を入力します。ここでは、「192.168.3.100」~「192.168.3.200」としています。

・リース期間

リースをする期間を入力します。ここでは、2時間を指定しています。

●DHCPオプション

DHCPのオプションには、以下の項目が設定できます。

  • DNS サーバ1
  • DNS サーバ2
  • ドメイン名
  • WINS サーバ1
  • WINS サーバ2
  • デフォルトルータ

 デフォルトルータの指定には、「192.168.3.1」を指定します。その他の項目は、今回の検証では任意の値で構いません。

各項目への入力が完了したら「OK」ボタンをクリックします。

「コマンド配信ステータス」が表示されます。

「OK」ボタンをクリックします。

スタティックルートの設定

左メニューの「ルーティング」をクリックし、「追加」をクリックします。

「IPスタティックルートの追加」が表示されます。

「192.168.3.0/24」へのルートを追加します。

ネクストホップには、「Ehternet0」を指定します。

「コマンド配信ステータス」が表示されます。

「OK」ボタンをクリックします。

上メニューの「保存」をクリックします。

これで、Router_AのDHCPサーバ機能の設定は完了です。