Serialのカプセル化(X.25)

※このページで解説している内容は、Packet Tracer が X25 に対応していないため、Packet Tracer で検証することができません。実機における検証結果を紹介しています。検証に使った実機は、古い機種です。

 WANに接続する際には、WANサービスに適合するデータリンク層のカプセル化を指定しなければなりません。Ciscoルータで選択できるWANのカプセル化の種類は、Serial のインターフェイスコンフィグレーションモードで「encapsulation ?」で確認することができます。

●Serialのカプセル化(Packet Tracer の場合)

 Packet Tracer の場合。frame-relay、hdlc、ppp の3つのデータリンク層のプロトコルに対応しています。

Router(config-if)#encapsulation ?
  frame-relay  Frame Relay networks
  hdlc         Serial HDLC synchronous
  ppp          Point-to-Point protocol
Router(config-if)#encapsulation 

●Serialのカプセル化(実機:Cisco2500の場合)

実機の場合は、多くのデータリンク層のプロトコルに対応しています。

Router(config-if)#encapsulation ?
  atm-dxi         ATM-DXI encapsulation
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

 CCNAの試験範囲において、WANのカプセル化は、「HDLC」、「PPP」、「farame-relay」が中心になっていますが、ここでは、「X.25」プロトコルについて、実機で検証した内容を紹介します。

 X.25は、パケット交換方式のネットワークで使用されるプロトコルです。X.25 が使われだした当初は、回線の品質が悪く、通信エラーの検出と訂正が必要でした。

 この通信エラーの検出と訂正があるために、高速通信を実現できないという欠点がありました。時代は流れて、通信回線の品質が高まり、通信エラーの確率も次第に改善されるようになってきます。そこで X.25 の後継のプロトコルとして「frame-relay(フレームリレー)」開発されました。

 フレームリレーでは、エラーの検出は行いますが、エラー訂正を省略したことにより通信速度を向上させています。「フレームリレー」については、別のコンテンツで紹介します。

それでは、下のネットワークを「X.25」プロトコルを使用して、ほんの少しだけ、「X.25」を体験してみます。

X.25の設定

「X.25」でカプセル化を行うには、シリアルインターフェイス上で、「encapsulation x25」コマンドを入力します。

●Router_Aの設定

Router(config)#interface serial 0
Router(config-if)#encapsulation x25 dce ddn

●Router_Bの設定

Router(config)#interface serial 0
Router(config-if)#encapsulation x25 dte ddn

詳しい「X.25」については、Ciscoのサイトを参考にしてみてください。

https://www.cisco.com/c/ja_jp/tech/wan/x-25-protocols/index.html

●Router_Aの設定


!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_A
!
enable password cisco
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.2.1 255.255.255.0
 ip mtu 576
 no ip mroute-cache
 encapsulation x25 dce ddn
 x25 address 000000010000
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

●Router_Bの設定


!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
 ip mtu 576
 no ip mroute-cache
 encapsulation x25 ddn
 x25 address 000000020000
!
interface Serial1
 no ip address
 shutdown
!
ip classless
logging buffered
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

 CCNA試験においては、「X.25」のトピックは試験範囲に含まれていませんが、ルータには、様々なデータリンク層のプロトロルがサポートされていることが体験できたと思います。