このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

VLAN間ルーティング(Router-on-a-stick:ROAS)

異なるVLAN間で通信を行うには、レイヤ3の機能が必要になってきます。つまり、ルータが必要になります。

異なるVLANを接続すするには、以下のような方法があります。

VLANと同じ数のリンクで各VLANを接続する方法

VLANと同じ数のだけ、ルータのEthernetのポートが必要になります。

サブインターフェイスにVLANのカプセル化を指定してトランク接続する方法

 RouterとSwitch間をトランクで接続する方法です。VLANごとにサブインターフェイスを作成し、VLANのカプセル化を行います。

VLAN間ルーティングの設定

それでは、下図のようにネットワークを構成し、VLAN間通信の設定を行っていきます。

ルータには、サブインタフェースを作成し、VLANカプセル化にはIEEE802.1Qを指定します。

 R_A の設定の「G0/0」に3つのサブインタフェースを作成し、次のIPアドレスを割り当て、VLANカプセル化には、「dot1q」を指定します。

  • G0/0.10 ・・・ 192.168.10.254/24
  • G0/0.20 ・・・ 192.168.20.254/24
  • G0/0.20 ・・・ 192.168.30.254/24

●サブインターフェイスの作成

サブインターフェイスを作成するには、グローバルコンフィギュレーションモードで、次のよう指定します。

Router(config)#interface FastEthernet <ポート番号>.<サブインターフェイス番号>

※サブインターフェイスの番号に「0」は使用できません。「0」は物理インターフェイス用に予約されています。

●VLANカプセル化の指定

 スイッチがサポートするVLANカプセル化は以下のようになります。ルータ側とスイッチ側で、カプセル化の指定を合わせておく必要があります。

「VLAN ID」には、サブインターフェイスに接続するVLAN番号を指定します。

Catalyst1900ISLのみサポート
Catalyst2900XLISL、IEEE802.1Q
Catalyst2950IEEE802.1Qのみサポート
Catalyst2960IEEE802.1Qのみサポート

Router(config-subif)#encapsulation { isl | dot1q} {VLAN ID}

●R_Aの設定

Router(config)#hostname R_A
R_A(config)#int g0/0
R_A(config-if)#no shutdown
R_A(config-if)#int g0/0.10
R_A(config-subif)#encapsulation dot1q 10
R_A(config-subif)#ip address 192.168.10.1 255.255.255.0
R_A(config-subif)#int g0/0.20
R_A(config-subif)#encapsulation dot1q 20
R_A(config-subif)#ip address 192.168.20.1 255.255.255.0
R_A(config-subif)#int g0/0.30
R_A(config-subif)#encapsulation dot1q 30
R_A(config-subif)#ip address 192.168.30.1 255.255.255.0
R_A(config-subif)#end

●R_Aののペースト用のコンフィグ

hostname R_A
int g0/0
no shutdown
int g0/0.10
encapsulation dot1q 10
ip address 192.168.10.1 255.255.255.0
int g0/0.20
encapsulation dot1q 20
ip address 192.168.20.1 255.255.255.0
int g0/0.30
encapsulation dot1q 30
ip address 192.168.30.1 255.255.255.0
end

●S_Aの設定

Switch(config)#hostname S_A
S_A(config)#vlan 10
S_A(config-vlan)#name vlan10
S_A(config-vlan)#vlan 20
S_A(config-vlan)#name vlan20
S_A(config-vlan)#vlan 30
S_A(config-vlan)#name vlan30
S_A(config-vlan)#int f0/1
S_A(config-if)#switchport mode access
S_A(config-if)#switchport access vlan 10
S_A(config-if)#int f0/2
S_A(config-if)#switchport mode access
S_A(config-if)#switchport access vlan 20
S_A(config-if)#int f0/3
S_A(config-if)#switchport mode access
S_A(config-if)#switchport access vlan 30
S_A(config-if)#int g0/1
S_A(config-if)#switchport mode trunk
S_A(config-if)#end

●S_Aのペースト用のコンフィグ

hostname S_A
vlan 10
name vlan10
vlan 20
name vlan20
vlan 30
name vlan30
int f0/1
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20
int f0/3
switchport mode access
switchport access vlan 30
int g0/1
switchport mode trunk

VLAN間通信の検証

 VLAN間、通信ができているかどうか、PC1からPC2へPingします。正しく設定が行えていれば、Pingは届くはずです。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。