このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

スイッチ仮想インターフェイス(SVI)と管理VLAN

 スイッチは、ルータのように物理インターフェイスにIPアドレスを割り当てることができません。

 スイッチを telnet で、ローカルやリモートで管理を行ったり、SNMPで管理したい場合には、スイッチ仮想インターフェイス(SVI)に IP アドレスを割り当てる必要があります。SVI (Switch Virtual Interface)とは仮想インターフェイスで、スイッチの物理ポートではなく、論理的なインターフェイスとなります。

 デフォルトでVLAN1という仮想インターフェイスが用意されており、VLAN1にIPアドレスを割り当てることで、リモートからスイッチを管理できるようになります。

 このデフォルトで用意されているVLAN1を、管理VLANといい、IPアドレスを設定することで、ローカルやリモートらからスイッチを管理できるようになります。

 管理VLANは、IPアドレスを割り当てるためだけのVLANではなく、CDPアドバタイズやVTPアドバタイズを伝送する重要なVLANになります。また、この管理VLANには、管理用のトラフィック(telnet や SNMP)も所属します。

管理VLAN(VLAN1)へのIPアドレスの割り当て

管理VLANは、以下のコマンドの「vlan-id」で指定したVLAN-IDが、管理VLANとなります。

Switch(config)#interface vlan {vlan-id}

まず、デフォルトの管理VLANであるVLAN1にIPアドレスを割り振って、Telnet接続を行ってみます。

 デフォルトで、VLAN1は用意されており、すべてのポートがVLAN1に所属しているため、新たにVLANを作成する必要はありません。

スイッチにIPアドレスとvty回線のパスワードを設定します。しておきます。

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit

Switch(config)#line vty 0 15
Switch(config-line)#password ccna
Switch(config-line)#login

PC1から、Switch に telnet 接続してみます。

telnetは、成功します。

管理VLANを変更する

管理VLANを変更するには、管理VLANとなっているVLAN1 を「shutdown」する必要があります。

デフォルトの管理VLANであるVLAN1を「shutdown」します。

Switch(config)#int vlan 1
Switch(config-if)#shutdown

それでは、スイッチの管理VLANを変更します。

管理VLANをVLAN1からVLAN2に変更します。

変更する前に、VLAN2を作成します。

Switch(config)#vlan 2
Switch(config-vlan)#name vlan2
Switch(config-vlan)#exit
Switch#conf t

F0/2にVLAN2を割り当てます。

Switch(config)#int f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit

管理VLANを変更します。

新しい管理VLANを設定するには、管理VLANに設定したいVLANを指定して、IPアドレスを割り当てます。

Switch(config)#int vlan 2
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)#no shutdown

設定が完了したら、telnet接続できるか確認してみます。

 ネットワークの構成は、そのままです。PCにつなげるスイッチのポートに変更はありません。「f0/1」は、VLAN1のままです。

PC2からTelnet接続を試みます。

telnetは成功します。

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。