このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

各PCのIPアドレスは、設定済みです

ネットワーク機器の設定と動作確認

 上図のネットワーク構成となるようスイッチとルータを設定します。デフォルトゲートウェイの設定は、ここではまだ行いません。

・PC1 から PC2 に対して ping を行います。

C:\>ping 192.168.2.10

Ping は成功します。

・PC1 から Switch に対して ping を行います。

C:\>ping 192.168.1.2

Ping は成功します。

・PC2 から Switch に対して ping を行います。

C:\>ping 192.168.1.2

Ping は失敗します。

 失敗する原因ですが、Switch にデフォルトゲートウェイを設定していないため、Switch にパケットが到着した後、戻りのパケットを Switch がデフォルトゲートウェイに送り返すことができないためです。

デフォルトゲートウェイの設定

 スイッチにデフォルトゲートウェイを設定するには、グローバル設定モードで「ip default-gateway」コマンドを使用します。

Switch#ip default-gateway <デフォルトゲートウェイのIPアドレス>

デフォルトゲートウェイの設定には、サブネットマスクの情報は、必要ないので注意して下さい。

 スイッチにデフォルトゲートウェイを設定しない場合は、スイッチにアクセスする端末は、同一ネットワーク内に制限されますが、スイッチにデフォルトゲートウェイを設定することで、端末が異なるネットワーク上にあってもアクセスできるようになります。

Switch にデフォルトゲートウェイを設定します。

●デフォルトゲートウェイの設定

Switch(config)#ip default-gateway 192.168.1.1

・再度、PC2 から Switch に対して ping を行います。

C:\>ping 192.168.1.2

今度は、Ping は成功します。

 これは、Switch にパケットが到着した後、戻りのパケットを Switch がデフォルトゲートウェイに送り返すことができるようになったためです。

Config

●Switch の Config

!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0

 no shutdown
!
ip default-gateway 192.168.1.1
!

●Router の Config

!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。