このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

allowed vlan とは

 下のネットワーク構成図を見て下さい。S1には、VLAN10、VLAN20、VLAN30が接続されています。S3には、VLAN10、VLAN30が接続されています。

 S3にVLAN20が接続されていません。つまり、S3には、VLAN20宛てのトラフィックは不要です。VLAN20宛てのトラフィックが、トランクリンクの帯域幅を圧迫してしまいかねません。

●allowed vlan 使わない場合

 「allowed vlan」 を使えば、トランクに不要なVLAN(VLAN20)トラフィックをフィルタすることができます。ただし、管理VLANであるVLAN1の情報はフィルタリングできません。

●allowed vlan を使う場合

基本設定(ペースト用コンフィグ)

まずは、VTPプルーニング以外の設定を行います。

●S1のコンフィグ
hostname S1
vlan 10
name vlan10
vlan 20
name vlan20
vlan 30
name vlan30
exit
int f0/1
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20
int f0/3
switchport mode access
switchport access vlan 30
int g0/1
switchport mode trunk
switchport nonegotiate

●S2のコンフィグ
hostname S2
vlan 10
name vlan10
vlan 20
name vlan20
vlan 30
name vlan30
exit
int f0/1
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20
int f0/3
switchport mode access
switchport access vlan 30
int g0/1
switchport mode trunk
switchport nonegotiate
int g0/2
switchport mode trunk
switchport nonegotiate

●S3のコンフィグ
hostname S3
vlan 10
name vlan10
vlan 30
name vlan30
exit
int f0/1
switchport mode access
switchport access vlan 10
int f0/3
switchport mode access
switchport access vlan 30
int g0/1
switchport mode trunk
switchport nonegotiate

基本設定後の検証

 トランクにしたリンクはデフォルトで、すべてのVLAN1を含む、すべてのVLANトラフィックが流れるようになっています。

「allowed vlan」を設定していないため、例えば、PC2からの通信が、S3スイッチに流れるはずです。

検証(allowed VLAN 設定前)

それでは、検証していきます。

・Packet Tracer をシミュレーションモードに切り替えます。

・「Show All/None」をクリックして、Event Listをクリアします。

・「Edit Filters」をクリックして、「ICMP」イベントのみチェックをいれます。

・PC2のコマンドプロンプトから、「ping 192.168.2.255」を実行します。

 C:\>ping 192.168.2.255

・Packet Tracer の時を1ステップずつ進めていきます。

S3にパケットが到達していることが確認できます。

・Packet Tracer をリアルタイムモードに切り替えます。

allowed vlan の設定

「allowed vlan」 を指定するには、以下のコマンドを使用します。

Switch(config-if)#switchport trunk allowed vlan {vlan-list}

S2のG0/2、S3のG0/1で各スイッチで以下のコマンドを実行します。

S1(config)#int g0/2
S1(config-if)#switchport trunk allowed vlan 10,30

S2(config)#int g0/1
S2(config-if)#switchport trunk allowed vlan 10,30

検証(allowed VLAN 設定後)

「allowed vlan」 を設定後、再度、検証していきます。

・Packet Tracer をシミュレーションモードに切り替えます。

・PC2のコマンドプロンプトから、「ping 192.168.2.255」を実行します。

 C:\>ping 192.168.2.255

・Packet Tracer の時を1ステップずつ進めていきます。

S3には、パケットが流れないことが確認できます。

・Packet Tracer をリアルタイムモードに切り替えます。

●S2の「show interfaces trunk」の出力

S2#show interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig0/1      on           802.1q         trunking      1
Gig0/2      on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig0/1      1-1005
Gig0/2      10,30

Port        Vlans allowed and active in management domain
Gig0/1      1,10,20,30
Gig0/2      10,30

Port        Vlans in spanning tree forwarding state and not pruned
Gig0/1      1,10,20,30
Gig0/2      10,30

●S3の「show interfaces trunk」の出力

S3#show interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Gig0/1      on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig0/1      10,30

Port        Vlans allowed and active in management domain
Gig0/1      10,30

Port        Vlans in spanning tree forwarding state and not pruned
Gig0/1      10,30

演習ファイル(完了)のダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習を完了させたファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。