このページで解説している内容は、以下の YouTube 動画の解説で見ることができます。

ネットワーク構成

ネットワークの構成は、下図のとおりです。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfeeインターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

Routerのパスワードは、以下のように設定しています。

  • enable password ・・・ cisco
  • line vty      ・・・ cisco

ルータやスイッチの設定をコピーペーストで復元する

保存しておいたルータやスイッチの設定を復元するにはいくつかの方法があります。

●ターミナルソフトの「ファイル」メニューを展開して設定ファイルを指定して転送する方法
●copy tftp running-config コマンドを使ってTFTPサーバ上の設定ファイルを指定してコピーする方法

などの方法がありますが、もっと簡単な方法があります。

それは、

●グローバル設定モードから、コンフィグを流し込む方法

です。

ここでは、グローバル設定モードから、コンフィグを流し込む方法について解説していきます。

設定をテキストエディタで編集する

「show running-config」コマンドで出力したコンフィグを選択コピーして、テキストエディタで編集していきます。

 まず、Router_Aで、「show running-config」コマンドを実行して、以下の個所をコピーして、テキストエディタにコピーします。

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router_A
!
!
!
enable password cisco
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524A727-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 172.16.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
!
!
end
!

 テキストエディタで、不要なコマンドや「!」を取り除いて、以下のように編集します。コンフィグを読みやすくするために、ある程度、「!」を残しておくのがおすすめです。

インターフェイスの設定のところで、「no shutdown」コマンドを追加しておきます。

 基本的に、コンフィグを転送する際は、あらかじめルータの設定を空にしておきます。ルータの設定が空の場合、インターフェイスはデフォルトで「shutdown」になっています。

 転送するコンフィグに「no shutdown」コマンドを追加していない場合は、転送後、各インタフェースがdownしたままの状態になっています。

 後から、各インターフェイス設定モードに入って「no shutdown」コマンドを入力するのは面倒なので、「no shutdown」を入れておきます。

!
hostname Router_A
!
enable password cisco
!
interface GigabitEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no shutdown ←インターフェイスをUPさせるために追加しておく
!
interface Serial0/0/0
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
 no shutdown ←インターフェイスをUPさせるために追加しておく
!
router rip
 network 172.16.0.0
!
line vty 0 4
 password cisco
 login
!
end
!

設定を復元する

 「no shutdown」コマンドを追加したら転送したい部分を選択して、「Ctrl + C」キーを押してクリップボードにコピーしておきます。

ルータにクリップボードにコピーした内容をルータに流し込みます。

ここが、重要です。

ルータに設定を流し込むには、グローバル設定モードに移行しておく必要があります。

 もし間違えて、違う設定モードでクリップボードの内容をルータに流し込むと、ルータがコマンドが解釈できなかったり、DNSにてコマンド名をホスト名として名前解決しようとして、しばらくの間、ルータは固まってしまいます。

ルータに設定を流し込む際は、必ずグローバル設定モードに移行しているかどうか確認してから行いましょう!

その前に、Router_Aの設定を空にして、再起動させます。

以下のコマンドを実行しておきます。

Router_A#erase startup-config
Router_A#reload

それでは、設定をルータに流し込んでみます。

グローバル設定モードに移行しておきます。

Router(config)#

のプロンプトのところで、「Ctrl + V」キーを押します。クリップボードにコピーしていた内容がルータ上で展開されます。

Router(config)#! ← ここで、コピーペーストを行います 
Router(config)#hostname Router_A
Router_A(config)#!
Router_A(config)#enable password cisco
Router_A(config)#!
Router_A(config)#interface GigabitEthernet0/0
Router_A(config-if)# ip address 172.16.1.1 255.255.255.0
Router_A(config-if)# no shutdown

Router_A(config-if)#!
Router_A(config-if)#interface Serial0/0/0
Router_A(config-if)# ip address 172.16.2.1 255.255.255.0
Router_A(config-if)# clock rate 64000
Router_A(config-if)# no shutdown

Router_A(config-if)#!
Router_A(config-if)#router rip
Router_A(config-router)# network 172.16.0.0
Router_A(config-router)#!
Router_A(config-router)#line vty 0 4
Router_A(config-line)# password cisco
Router_A(config-line)# login
Router_A(config-line)#!
Router_A(config-line)#end
Router_A#!

 このルータへの設定コンフィグを流し込む方法を使えば、わざわざ各ルータで1つずつコマンドで設定しなくて済みます。テキストファイル上でコンフィグの内容を編集することで、ルータの設定時間を短縮することができます。