パスワードの設定

このページで解説している内容は、以下のYoutube動画の解説で見ることができます。

ここでは、ルータに設定する各種パスワードの設定方法を解説していきます。

ネットワークの構成

基本設定を済ませた演習ファイルは、下記からダウンロードできます。

演習ファイルのダウンロード

 ネットワークの構成を Packet Tracer で一から設定していくのは大変かと思います。「ダウンロード」ボタンから演習で使用するファイルのダウンロードができます。ファイルは、McAfee インターネットセキュリティでウイルスチェックをしておりますが、ダウンロードは自己責任でお願いいたします。

コンソールパスワードの設定

 実際のルータの場合、ルータの設定を行うには、下図のようにルータの CONSOLE にコンソールケーブルを差し込んでターミナルソフトを起動してルータにアクセスします。

ルータが起動すると下のようなプロンプトが表示されます。

Router>enable

これだと、コンソール接続されてしまうと、誰もが、このルータにアクセスできてしまいます。

 そこで、コンソールパスワードを設定します。そうすることでコンソールポートからログインする度に、パスワードを要求するようになります。

●コンソールパスワードの設定

Router(config)#line console 0  ← ライン設定モードに切り替える
Router(config-line)#password cisco ← パスワードを「cisco」の設定
Router(config-line)#login ← ログイン時にパスワードを要求

このように、ユーザモードに入る前にパスワードが要求されるようになります。

Press RETURN to get started!

User Access Verification

Password:

特権モードのパスワード(暗号化なし)

パスワードを暗号化しない特権モードへのパスワードの設定は、「enable password」コマンドで設定します。

Router(config)#enable password cisco ← 特権モードへのパスワードを「cisco」に設定

パスワードを設定すると特権モードへ移行する時、パスワードが表示されるようになります。

Router>enable
Password:

しかし、「show running-config」コマンドを実行されるとパスワードが、ばれてしまいます。

Router#show running-config

Building configuration…

Current configuration : 650 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
enable password cisco ← パスワードが丸見え

特権モードのパスワード(暗号化あり)

 特権モードのパスワード設定で、「enable password」コマンドを使用するとコンフィグを確認されるとパスワードが丸見えでした。そこで、パスワードを暗号化するコマンドが用意されています。パスワードを暗号化するには、「enable secret」コマンドを使います。

Router(config)#enable secret class ← 特権モードへのパスワードを「class」に設定

「show running-config」して確認すると暗号化されているのが分かります。

Router#show running-config
Building configuration…

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1 ← パスワードが暗号化
enable password cisco
!

 「enable password」コマンドと「enable secret」コマンドの両方を設定した場合は、暗号化される「enable secret」コマンドで設定したパスワードが優先されます。

Telnetのパスワード設定

 Telnetでログインできるようにするには、Telnetのパスワードを設定する必要があります。Telnetのパスワードが設定されていない場合、Telnetでのログインができません。

Router(config)#line vty 0 4  ← ライン設定モードに切り替える
Router(config-line)#password cisco ← パスワードを「cisco」に設定
Router(config-line)#login ← ログイン時にパスワードを要求

 「vty」とは、Telnetのための仮想ポートで0番~4番の5つが用意されています。通常、これらは、まとめて設定しますので、「line vty 0 4」のように、5つまとめて指定します。

 vtyのパスワードを設定すると、Telnetでアクセスするとログイン画面が表示されるようになります。ここで、設定したパスワードを入力することでログインできるようになります。

Laptop の Command Prompt からルータにアクセスします。

c:\telnet 192.168.1.1

と入力します。

「service password-encryption」コマンドによる暗号化

 「enable secret」以外は、「show running-config」コマンドで確認すると、パスワードが丸見えです。コンソールや仮想端末などのパスワードを暗号化して表示したい場合は、「service password-encryption」コマンドを使います。

Router(config)#service password-encryption

暗号化した後、「show running-config」コマンドで、確認してみると下のように、ちゃんと暗号化されていることが確認できます。

Router#show running-config
Building configuration…

Current configuration : 757 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
enable password 7 0822455D0A16
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524BRSN-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
!
end