配布リスト IGRP(ACL・prefix-list)

ここでは、IGRPネットワークで以下の設定を行いルートフィルタリングの検証を行います。

  • ACLを使用した配布リストの設定
  • プレフィックスリストを使用した配布リストの設定

まずは、下のネットワークをIGRPで構築します。

検証には、IOS12.0を搭載するCisco2611を使用しています。

各ルータの設定は、以下のようになります。

●Router_Aの設定


!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
 ip address 10.0.0.1 255.0.0.0
!
interface Loopback1
 ip address 20.0.0.1 255.0.0.0
!
interface Ethernet0/0
 ip address 172.16.0.1 255.255.0.0
!
router igrp 100
 network 10.0.0.0
 network 20.0.0.0
 network 172.16.0.0
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

●Router_Bの設定

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 172.16.0.2 255.255.0.0
!
router igrp 100
 network 172.16.0.0
!
ip classless
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end

 ルータの設定が完了したら、「copy run start」して保存しておきます。後ほど、この設定状態から、再設定できるようにしておきます。

Router_Bに「10.10.10.0/24」の経路情報をアドバタイズしないようにルートフィルタリングの設定をしていきます。

ACLを使用した配布リストの設定

Router_Aに次の設定を追加します。

Router_A(config)#access-list 1 deny 10.0.0.0 0.255.255.255
Router_A(config)#access-list 1 permit any
Router_A(config)#router igrp 100
Router_A(config-router)#distribute-list 1 out ethernet 0/0

Router_Bのルーティングテーブルをクリアします。

Router_B#clear ip route *

Router_Bのルーティングテーブルを確認します。

●Router_Bのルーティングテーブル

Gateway of last resort is not set

I    20.0.0.0/8 [100/1600] via 172.16.0.1, 00:00:03, Ethernet0/0
C    172.16.0.0/16 is directly connected, Ethernet0/0

Router_Aから「10.10.10.0/24」の経路情報が伝播されていないことが確認できます。

次に、プレフィックスリストを使用した配布リストの設定を行います。

Router_Aをリロードします。

Router_A#reload

プレフィックスリストを使用した配布リストの設定

Router_Aに次の設定を追加します。

Router_A(config)#ip prefix-list net-filter seq 10 deny 10.0.0.0/8
Router_A(config)#ip prefix-list net-filter seq 15 permit 0.0.0.0/0 le 32
Router_A(config)#router igrp 100
Router_A(config-router)#distribute-list prefix net-filter out ethernet 0/0

Router_Bのルーティングテーブルをクリアします。

Router_B#clear ip route *

Router_Bのルーティングテーブルを確認します。

●Router_Bのルーティングテーブル


Gateway of last resort is not set

I    20.0.0.0/8 [100/1600] via 172.16.0.1, 00:00:03, Ethernet0/0
C    172.16.0.0/16 is directly connected, Ethernet0/0

Router_Aから「10.10.10.0/24」の経路情報が伝播されていないことが確認できます。

次の「配布リスト EIGRP(ACL・prefix-list)」では、EIGRPにおける配布リストの設定を紹介します。