VPN(トンネル・エンドポイント・ディスカバリ 5)

 「VPN(トンネル・エンドポイント・ディスカバリ 4)」の続きです。ここでは、追加する拠点CのRouter_Cを設定していきます。

※Router_B、Router_CのE0は、「no keepalive」コマンドで、強制的にUPさせます。

◆Router_Cの設定

●初期設定

Rouer#conf t
Router(config)#hostname Router_C
Router_C(config)#enable password cisco
Router_C(config)#line vty 0 4
Router_C(config-line)#password cisco
Router_C(config-line)#login
Router_C(config-line)#exit
Router_C(config)#int e0
Router_C(config-if)#ip address 172.18.0.1 255.255.0.0
Router_C(config-if)#no keepalive
Router_C(config-if)#no shutdown
Router_C(config-if)#exit
Router_C(config)#int f0
Router_C(config-if)#ip address 20.0.0.3 255.0.0.0
Router_C(config-if)#no shutdown
Router_C(config-if)#exit

●IPsec対象トラフィックの定義

Router_C(config)#access-list 100 permit ip 172.18.0.0 0.0.255.255 172.16.0.0 0.0.255.255
Router_C(config)#access-list 101 permit ip 172.18.0.0 0.0.255.255 172.17.0.0 0.0.255.255

●スタティックルートの設定

Router_C(config)#ip route 172.16.0.0 255.255.0.0 20.0.0.1
Router_C(config)#ip route 172.17.0.0 255.255.0.0 20.0.0.2

●VPNの設定

Router_C(config)#crypto isakmp policy 1
Router_C(config-isakmp)#authentication pre-share
Router_C(config-isakmp)#exit

↓対向ルータのアドレスは「0.0.0.0」を指定します。
Router_C(config)#crypto isakmp key cisco address 0.0.0.0 0.0.0.0

Router_C(config)#crypto ipsec transform-set TS-IPSEC esp-3des esp-sha-hmac
Router_C(cfg-crypto-trans)#mode tunnel
Router_C(cfg-crypto-trans)#exit

↓「crypto dynamic-map」を作成します。
Router_C(config)#crypto dynamic-map MAP-IPSEC 1
Router_C(config-crypto-map)#set transform-set TS-IPSEC
Router_C(config-crypto-map)#match address 100
Router_C(config-crypto-map)#exit

Router_C(config)#crypto dynamic-map MAP-IPSEC 2
Router_C(config-crypto-map)#set transform-set TS-IPSEC
Router_C(config-crypto-map)#match address 101
Router_C(config-crypto-map)#exit

↓「crypto map」で「crypto dynamic-map」を指定します。
Router_C(config)#crypto map TEDTAG 1 ipsec-isakmp dynamic MAP-IPSEC discover

Router_C(config)#interface fastEthernet 0
Router_C(config-if)#crypto map TEDTAG
Router_C(config)#exit

各ルータのコンフィグは、次の「VPN(トンネル・エンドポイント・ディスカバリ 6)」で紹介します。